Modify

Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#7135 closed defect (fixed)

wireless-testing 2010-04-09 non-working wifi on planex mzk-W04nu

Reported by: Will Dyson <will.dyson@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: ath9k Cc:

Description

After r20777, the ath9k driver no-longer loads properly on my Planex mzk-W04nu. Relevant dmesg excerpt below:

ath: timeout (100000 us) on reg 0x7044: 0xdeadbeef & 0x0000000f != 0x00000002
ath: Couldn't reset chip
ath: Unable to initialize hardware; initialization status: -5
ath9k ath9k: failed to initialize device
ath9k: probe of ath9k failed with error -5

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by tlm

I confirm, r20776 is ok.
In dmesg I only have
ath9k ath9k: failed to initialize device
ath9k: probe of ath9k failed with error -5
though

comment:2 Changed 8 years ago by tlm

Forgot to say I have a tl-wr1043nd

comment:3 Changed 8 years ago by admin@…

Hi,

I also confirm the issue. I tried to run trunk 20790 on a mzk-W04nu but I had to rollback to 20776 in order to have the wireless interface working

Thanks

comment:4 Changed 8 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in r20849

comment:5 Changed 5 years ago by banglang.huang@…

Hi , I have a same problem with you this time,my testbed is Atheros DB120 board,and the 5GHz wifi interface can not be brang up.
Could you please tell me how to fix it?

ath9k ath9k: failed to initialize device
ath9k: probe of ath9k failed with error -5

the issue is at compat-wireless/net/drivers/ath/ath9k/
...ath9k_hw_eeprom_init() error I/O,

comment:6 Changed 4 years ago by codemarauder@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I am running OpenWrt 12.09 on AMD T-40N hardware with AR9820 chipset Compex WLE200NX mPCIe card. The kernel version is 3.3.8 and it is compiled with SMP support.

The wireless card is not initialized. Following is the output when I removed the module and loaded as:

modprobe -v ath9k debug=0xffffffff

[ 409.517378] bus: 'pci': add driver ath9k
[ 409.521403] bus: 'pci': driver_probe_device: matched device 0000:04:00.0 with driver ath9k
[ 409.529721] bus: 'pci': really_probe: probing driver ath9k with device 0000:04:00.0
[ 409.650243] ath: phy2: timeout (100000 us) on reg 0x7044: 0xffffffff & 0x0000000f != 0x00000002
[ 409.658983] ath: phy2: RTC not waking up
[ 409.662919] ath: phy2: Couldn't reset chip
[ 409.667026] ath: phy2: Unable to initialize hardware; initialization status: -5
[ 409.674344] ath9k 0000:04:00.0: Failed to initialize device
[ 409.679968] ath9k: probe of 0000:04:00.0 failed with error -5

I have also enabled debugfs support for atheros but there is nothing inside /sys/kernel/debug/ieee80211/

Let me know what more information needs to be provided.

comment:7 Changed 4 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

different error, different device, different software version - what you're describing doesn't have much to do with this ticket. The first thing you should do is try a snapshot build of OpenWrt to see if it's fixed there.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.