Modify

Opened 8 years ago

Closed 6 years ago

Last modified 4 years ago

#7119 closed defect (worksforme)

Backfire 10.03 (brcm-2.4) not working on Asus WL-500G

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Backfire 10.03
Keywords: Cc:

Description

Tried to flash brcm-2.4 of both 10.03-rc3 and 10.03 on my Asus WL-500G (i.e. original model), and the power led doesn't come back on after rebooting.

I also copied the new busybox release from backfire to Kamikaze 8.09.2, after flashing the power led does go on but I cannot connect to the router through either telnet or ssh

Unfortunately I don't have a serial port console to tell what's going on, so this is just FYI to flag the problem

Attachments (0)

Change History (12)

comment:1 Changed 8 years ago by nico

  • Version changed from Trunk to Backfire 10.03

comment:2 Changed 8 years ago by mauritzius@…

Same problem here, the 2.6 version boots fine, but there is this nasty ethernet-bug!
Unfortunately, I also don't have serial console.

comment:3 Changed 8 years ago by opennet@…

Same here, serial available. Feels like firstrun is missing? Any idea how to trace further?

root@OpenWrt:~# mtd -r write openwrt-brcm-2.4-squashfs.trx linux
Unlocking linux ...                                             
Writing from openwrt-brcm-2.4-squashfs.trx to linux ... Restarting system.

Please stand by while rebooting the system...
CPU revision is: 00024000                    
Enabling BCM4710A0 cache workarounds.        
Primary instruction cache 8kB, physically tagged, 2-way, linesize 16 bytes.
Primary data cache 4kB, 2-way, linesize 16 bytes.                          
Linux version 2.4.37.9 (openwrt@wrt1.marcant.net) (gcc version 3.4.6 (OpenWrt-2.0)) #42 Tue Apr 6 15:59:040
Determined physical RAM map:                                                                               
 memory: 01000000 @ 00000000 (usable)                                                                      
On node 0 totalpages: 4096                                                                                 
zone(0): 4096 pages.                                                                                       
zone(1): 0 pages.                                                                                          
zone(2): 0 pages.                                                                                          
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0
CPU: BCM4710 rev 0 at 125 MHz                                                                              
Using 62.400 MHz high precision timer.                                                                     
Calibrating delay loop... 82.94 BogoMIPS                                                                   
Memory: 14240k/16384k available (1447k kernel code, 2144k reserved, 100k data, 84k init, 0k highmem)       
Dentry cache hash table entries: 2048 (order: 2, 16384 bytes)
Inode cache hash table entries: 1024 (order: 1, 8192 bytes)                                                
Mount cache hash table entries: 512 (order: 0, 4096 bytes)                                                 
Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)                                               
Page-cache hash table entries: 4096 (order: 2, 16384 bytes)                                                
Checking for 'wait' instruction...  unavailable.                                                           
POSIX conformance testing by UNIFIX                                                                        
PCI: Initializing host                                                                                     
PCI: Fixing up bus 0                                                                                       
PCI: Fixing up bridge                                                                                      
PCI: Fixing up bus 1                                                                                       
Linux NET4.0 for Linux 2.4                                                                                 
Based upon Swansea University Computer Society NET3.039                                                    
Initializing RT netlink socket                                                                             
Starting kswapd                                                                                            
Registering mini_fo version $Id$                                                                           
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)                                              
devfs: boot_options: 0x1                                                                                   
JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.                             
squashfs: version 3.0 (2006/03/15) Phillip Lougher                                                         
pty: 256 Unix98 ptys configured               
Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled                      
ttyS00 at 0xbf800008 (irq = 2) is a 16550A                                                                 
b44.c:v0.93 (Mar, 2004)                                                                                    
eth0: Broadcom 47xx 10/100BaseT Ethernet 00:11:d8:1b:fa:a4                                                 
eth1: Broadcom 47xx 10/100BaseT Ethernet 00:11:d8:1b:fa:a4                                                 
 Amd/Fujitsu Extended Query Table v1.1 at 0x0040                                                           
Physically mapped flash: Swapping erase regions for broken CFI table.                                      
number of CFI chips: 1                                                                                     
cfi_cmdset_0002: Disabling fast programming due to code brokenness.                                        
Flash device: 0x400000 at 0x1fc00000                                                                       
bootloader size: 262144                                                                                    
Physically mapped flash: Filesystem type: squashfs, size=0x1a68f2                                          
Updating TRX offsets and length:                                                                           
old trx = [0x0000001c, 0x00000904, 0x0007c000], len=0x00251000 crc32=0x581f7411                            
new trx = [0x0000001c, 0x00000904, 0x0007c000], len=0x00230000 crc32=0x3f83d157                            
Done                                                                                                       
Creating 5 MTD partitions on "Physically mapped flash":                                                    
0x00000000-0x00040000 : "cfe"                                                                              
0x00040000-0x003f0000 : "linux"                                                                            
0x000bc000-0x00270000 : "rootfs"                                                                           
mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only                        
0x003f0000-0x00400000 : "nvram"
0x00270000-0x003f0000 : "rootfs_data"                                                                      
sflash: chipcommon not found                                                                               
Initializing Cryptographic API                                                                             
NET4: Linux TCP/IP 1.0 for NET4.0                                                                          
IP Protocols: ICMP, UDP, TCP, IGMP                                                                         
IP: routing cache hash table of 512 buckets, 4Kbytes                                                       
TCP: Hash tables configured (established 1024 bind 2048)                                                   
Linux IP multicast router 0.06 plus PIM-SM                                                                 
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.                                                        
NET4: Ethernet Bridge 008 for NET4.0                                                                       
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>                                              
All bugs added by David S. Miller <davem@redhat.com>                                                       
VFS: Mounted root (squashfs filesystem) readonly.                                                          
Mounted devfs on /dev                                                                                      
Freeing unused kernel memory: 84k freed                                                                    
mount: mounting sysfs on /sys failed: No such device                                                       
mount: mounting devfs on /dev failed: Device or resource busy                                              
diag: Detected 'ASUS WL-500g'
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
roboswitch: Probing device eth0: No Robo switch in managed mode found, phy_id = 0xffffffff
roboswitch: Probing device eth1: No Robo switch in managed mode found, phy_id = 0xffffffff
roboswitch: Probing device eth2: No such device
roboswitch: Probing device eth3: No such device
- preinit -
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
Press the [f] key and hit [enter] to enter failsafe mode
- regular preinit -
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
jffs2 not ready yet; using ramdisk
mini_fo: using base directory: /
mini_fo: using storage directory: /tmp/root
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
- init -
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.

Please press Enter to activate this console.



root@(none):/# ps
  PID USER       VSZ STAT COMMAND
    1 root      1408 S    init
    2 root         0 SW   [keventd]
    3 root         0 SWN  [ksoftirqd_CPU0]
    4 root         0 SW   [kswapd]
    5 root         0 SW   [bdflush]
    6 root         0 SW   [kupdated]
    9 root         0 SW   [mtdblockd]
  102 root      1404 S    /bin/sh /etc/init.d/rcS S boot
  103 root      1420 S    /bin/ash --login
  104 root      1408 S    /bin/sh /etc/init.d/rcS S boot
  106 root      1400 S    logger -s -p 6 -t sysinit
  131 root      1408 R    /bin/sh /etc/init.d/rcS S boot
  148 root      1400 R    ps
root@(none):/#


comment:4 Changed 8 years ago by opennet@…

Hi, couldn't find any reason for the problems, all scripts are stopping irregularly, mostly while accessing storage (as I feel). Tried to rebuild backfire with strace - and couldn't trace anything, it just works as it should.

Strange thing, currently no time to investigate further, you can find the working backfire-image at

http://www.absorb.it/software/opennet/backfire_wl500g/

Will check this again in July,

Rene

comment:5 Changed 7 years ago by Rolf Leggewie <dev.openwrt.org@…>

did you erase configuration/nvram. IIRC that was necessary for me when switching between 2.6 and 2.4 images for a similar model.

comment:6 Changed 7 years ago by marktheblake@…

I have also being unabled to load Backfire 10.03 on the WL-500G, same symptons.

now is the image provided on this page working http://www.absorb.it/software/opennet/backfire_wl500g

has anyone resolved this further?

comment:7 Changed 7 years ago by marktheblake@…

Sorry, i meant the this image is NOT working also http://www.absorb.it/software/opennet/backfire_wl500g/

comment:8 Changed 7 years ago by anonymous

Mark, did you erase the configuration and nvram?

comment:9 Changed 7 years ago by marktheblake <s5pXm1ts>

I used these files first, wl500g-clear-nvram.trx and wl500g-recover.trx
is that what you mean?

then i follow instructions on this page http://wiki.openwrt.org/oldwiki/openwrtdocs/hardware/asus/wl500g

at the moment the only firmware I can get to install successfully is the last White Russian, which is dissapointing, the knowledge base tells me backfire is compatible

comment:10 Changed 7 years ago by anonymous

IIRC, "mtd erase nvram;reboot" is what did the trick for me in a similar situation. I was downgrading from a 2.6 kernel to a 2.4 kernel.

comment:11 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:12 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.