Modify

Opened 11 years ago

Closed 10 years ago

Last modified 4 years ago

#711 closed defect (wontfix)

WL-500GP and IPW2200BG segfaults while loading module

Reported by: bachmanns@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: ipw2200 wl-500gp premium Cc:

Description

Hi, I equiped my WL-500GP with an Intel Wireless Pro/2200BG Card and tried to load the ipw2200 driver in Kamikaze but segfaults. dmesg shows:

<6>ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, git-1.1.1
<6>ipw2200: Copyright(c) 2003-2006 Intel Corporation
<4>PCI: Enabling device 0000:01:02.0 (0000 -> 0002)
<4>PCI: Fixing up device 0000:01:02.0
<7>PCI: Setting latency timer of device 0000:01:02.0 to 64
<6>ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
<1>Data bus error, epc == c009dc0c, ra == c00a9ac8
<4>Oops[#1]:
<4>Cpu 0
<4>$ 0   : 00000000 10009c00 c005e000 c005e000
<4>$ 4   : 808eaa14 00000000 00000001 000000fa
<4>$ 8   : 00000000 c005e024 80240000 fff7ffff
<4>$12   : 00200200 00100100 00000001 2abdee34
<4>$16   : 00000000 00000000 80240000 c009dbfc
<4>$20   : 802e88b0 808eaa14 00000000 c0111000
<4>$24   : 2abd97a4 801255d8                  
<4>$28   : 80fd8000 80fd9c38 0000012d c00a9ac8
<4>Hi    : fd565f87
<4>Lo    : bc9d7d03
<4>epc   : c009dc0c     Not tainted
<4>ra    : c00a9ac8 Status: 10009c03    KERNEL EXL IE 
<4>Cause : 0000001c
<4>PrId  : 00029006
<4>Modules linked in: ipw2200 ieee80211 ieee80211_crypt
<4>Process insmod (pid: 451, threadinfo=80fd8000, task=803e3420)
<4>Stack : 00000042 10009801 00000044 c00affa8 00000000 802e6c14 80fd9ce0 80fd9ce3
<4>        80210000 ffffffff 00000002 80fd9cef 80fd9ce0 00000010 0000012d 80055484
<4>        00028020 00000000 808af680 00000000 c0111010 c0112950 c0116916 00000003
<4>        808ea000 808ea000 808eaa14 808eaa18 808ea000 801d0000 802e88b0 802e8800
<4>        c00b0000 808eaa18 0000012d c00aac84 802e88b0 8014b144 808af780 8004da88
<4>        ...
<4>Call Trace: [<80055484>]  [<801d0000>]  [<c00aac84>]  [<8014b144>]  [<8004da88>]  [<8014e3a0>]  [<8014e7f4>]  [<c00ab440>]  [<c00aaeac>]  [<800f18e4>]  [<8011cd60>]  [<8010438c>]  [<80104350>]  [<80104278>]  [<800f23f4>]  [<8011f5bc>]  [<801d0dd8>]  [<8011f944>]  [<8011f7d0>]  [<8011e3dc>]  [<8011f7d0>]  [<8011e440>]  [<800f1cf8>]  [<8002d8cc>]  [<8011ed70>]  [<8002d8cc>]  [<801202cc>]  [<8002d8cc>]  [<8010415c>]  [<8002d8e8>]  [<800bb320>]  [<c0058054>]  [<8004c780>]  [<80012a80>] 
<4>
<4>Code: 3c0a8024  00454821  00002821 <8d220000> 00461024  14460003  8d433460  03e00008  00a01021 

Please let me know if I can provide you with more information.

Sven

Attachments (0)

Change History (17)

comment:1 Changed 11 years ago by florian

Did you also loaded the ipw firmware to your router ?

comment:2 Changed 11 years ago by bachmanns@…

Hi Florian,

yes I did load the firmware to the router.

Bye

Sven

comment:3 Changed 11 years ago by florian

Which firmware do you use ?

comment:4 Changed 11 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Should be working better now with kamikaze.

comment:5 Changed 11 years ago by walter@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hello,
I equipped my WL-500GP with an Intel 2915 a/b/g wireless card. I'm running Kamikaze 7.06, Linux-kernel

root@OpenWrt:/# uname -a
Linux OpenWrt 2.6.19.2 #8 Fri Jun 1 15:58:48 CEST 2007 mips unknown

When the ipw2200 kernel module tries to load the Intel Firmware, the Kernel Module segfaults
I use the firmware v3.0 from http://ipw2200.sourceforge.net/firmware.php
I tried the latest kamikaze SVN-Checkout r7718 there is the same effect

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.4kmq
ipw2200: Copyright(c) 2003-2006 Intel Corporation
PCI: Enabling device 0000:00:02.0 (0000 -> 0002)
PCI: Fixing up device 0000:00:02.0
PCI: Setting latency timer of device 0000:00:02.0 to 64
ipw2200: Detected Intel PRO/Wireless 2915ABG Network Connection
Data bus error, epc == c00c5398, ra == c00c800c
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000d800 c0090000 c00c0000
$ 4   : 81ecea38 00000000 00000001 000000fa
$ 8   : 00000000 800fbb70 c0090024 00100000
$12   : 80260000 810aba63 ffffffff 00000000
$16   : 00000000 00000000 801f0000 81ece000
$20   : 00000000 81ecea38 00000000 c0092000
$24   : 00000000 00000000
$28   : 810aa000 810abbf8 c00e0000 c00c800c
Hi    : e8b67392
Lo    : 4e1c3d83
epc   : c00c5398     Not tainted
ra    : c00c800c Status: 1000d803    KERNEL EXL IE
Cause : 0000801c
PrId  : 00029006
Modules linked in: ipw2200 ip_conntrack_tftp ip_nat_irc ip_conntrack_irc ip_nat_ftp ip_conntrack_ftp ppp_async ppp_generic slhc crc_ccitt ieee80211_crypt_ccmp ieee80211_crypt_tkip ieee80211_crypt_wep ieee80211 ieee80211_crypt switch_robo switch_core diag
Process insmod (pid: 1392, threadinfo=810aa000, task=810a88f8)
Stack : 80270000 813bfd00 80270000 800b3350 00000006 81d87180 810abc58 c00dc440
        00000238 81d87180 813bfd32 81d87180 00000006 800b3994 8021101a 00000000
        810abc54 c00df470 810abc58 8004b4a0 00000043 810ccc00 81d87200 c0092010
        c0093950 c0097916 00000003 00008020 810abcec 810abcf7 c00e0000 81ecea38
        801f0000 81ece000 00000000 810ccc00 c00e0000 81ecea3c c00e0000 c00d5e84
        ...
Call Trace:[<800b3350>][<800b3994>][<8004b4a0>][<c00d5e84>][<800faf58>][<800fa7a8>][<c00d681c>][<80049810>][<80155164>][<801573ac>][<c00d70d8>][<c00d6a4c>][<800f6018>][<8001f2c8>][<80121f68>][<801090b0>][<80108e94>][<80125650>][<801257e0>][<800bae74>][<80125b84>][<8012459c>][<800f6344>][<80125a18>][<801246b0>][<80124adc>][<80024df0>][<801092ec>][<c00e3054>][<80048890>][<8000cdc0>]

Code: 3c0b0010  00455021  00002821 <8d420000> 00461024  14460003  8d8300e0  03e00008  00a01021

Any suggestions what's goin' wrong ??

comment:6 Changed 10 years ago by foobeer@…

This happens at my brcm4710 based router as well. I tried kamikaze 7.0 7 as well as the latest kamikaze-snapshot, both of them segfaulted that way. I also tried version 1.2.2 (kmq && only k) of ipw2200 with the same result. I used v3.0 of the firmware.

I used a Intel PRO/Wireless 2915ABG mini-pci card.

Actually, does someone have a ipw2200 card running on a mipsel device?

Bye, Andreas.

comment:7 Changed 10 years ago by foobeer@…

Never mind that (pretty dirty) 1.2.2 try.

comment:8 Changed 10 years ago by foobeer@…

I took a look, enabled debug and got:

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.0kdmq
ipw2200: Copyright(c) 2003-2006 Intel Corporation
PCI: Fixing up device 0000:00:01.0
ipw2200: U ipw_pci_probe pci_resource_len = 0x00001000
ipw2200: U ipw_pci_probe pci_resource_base = c0064000
ipw2200: U ipw_qos_init QoS is not enabled
ipw2200: U ipw_sw_reset Hardware crypto [off]
ipw2200: Detected Intel PRO/Wireless 2915ABG Network Connection
ipw2200: U ipw_get_fw Read firmware 'ipw2200-bss.fw' image v3.0 (191126 bytes)
ipw2200: U ipw_load drivers/net/wireless/ipw2200.c 3450: write_direct32(0x000000
0C, 0x3ACE07CD)
ipw2200: U ipw_load drivers/net/wireless/ipw2200.c 3454: write_direct32(0x000000
08, 0xC531F832)
ipw2200: U ipw_stop_nic drivers/net/wireless/ipw2200.c 3210: write_direct32(0x00
000020, 0x00000200)
ipw2200: U __ipw_read32 drivers/net/wireless/ipw2200.c 2982: read_direct32(0x000
00020)
ipw2200: U __ipw_read32 drivers/net/wireless/ipw2200.c 525: read_direct32(0x0000
0020)
ipw2200: U ipw_set_bit drivers/net/wireless/ipw2200.c 525: write_direct32(0x0000
0020, 0x00000301)
ipw2200: U __ipw_read32 drivers/net/wireless/ipw2200.c 525: read_direct32(0x0000
0020)
ipw2200: U ipw_reset_nic >>
ipw2200: U ipw_init_nic >>
ipw2200: U __ipw_read32 drivers/net/wireless/ipw2200.c 525: read_direct32(0x0000
0024)
ipw2200: U ipw_set_bit drivers/net/wireless/ipw2200.c 525: write_direct32(0x0000
0024, 0x000007C4)
ipw2200: U __ipw_read32 drivers/net/wireless/ipw2200.c 525: read_direct32(0x0000
0024)
ipw2200: U ipw_init_nic drivers/net/wireless/ipw2200.c 3253: write_direct32(0x00
000FF4, 0x20000000)
ipw2200: U __ipw_read32 drivers/net/wireless/ipw2200.c 2982: read_direct32(0x000
00024)
Data bus error, epc == c00b5a94, ra == c00b5a8c
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000f000 802c2000 80240000
$ 4   : 80239b00 00000001 00000001 00000000
$ 8   : 80239b00 80240000 80280000 80280000
$12   : 80280000 80b5fa52 80278d04 00000000
$16   : 00000000 00000001 00000024 000000fa
$20   : 80b96b40 c00d0000 c00d0000 c00d0000
$24   : 00000000 80203bfc
$28   : 80b5e000 80b5fb90 00000049 c00b5a8c
Hi    : 000000a0
Lo    : 0000008c
epc   : c00b5a94     Not tainted
ra    : c00b5a8c Status: 1000f003    KERNEL EXL IE
Cause : 0000001c
PrId  : 00024000
Modules linked in: ipw2200 ieee80211_crypt_ccmp ieee80211_crypt_tkip ieee80211_c
rypt_wep ieee80211 ieee80211_crypt
Process insmod (pid: 1369, threadinfo=80b5e000, task=80b58000)
Stack : 00000024 00000055 c00d203c c00d6c18 00000ba6 00000024 c00e0000 0000020d
        00000024 80023454 80b96b40 c00c3334 00000061 00000055 c00d635c c00d6c18
        00000cb5 00000ff4 20000000 8001c418 80d19780 00001000 80b5fc00 8004ac0c
        00000003 c00e4916 c00e0950 c00df010 c00df000 00000000 80b96b40 80b96b40
        80b96b40 80b96000 80200000 802c2000 802c20b0 00000000 0fffff00 c00c4e70
        ...
Call Trace:[<80023454>][<c00c3334>][<8001c418>][<8004ac0c>][<c00c4e70>][<c00cf48
c>][<801601ac>][<80048bb0>][<8015dfb8>][<c00d0000>][<80160218>][<c00d1110>][<c00
d0a94>][<8008c7e0>][<c006a29c>][<8010ed2c>][<8012c2a4>][<801f7f5c>][<800bd85c>][
<8012c714>][<8012af2c>][<800f9570>][<8012c5ac>][<8012b098>][<c006a29c>][<8012b4b8>][<8010ef44>][<80023454>][<c0061058>][<80047898>][<8000bc60>]

Code: afb20014  8e820018  00521021 <8c420000> 00511024  10510012  3c028027  8c43
0d60  3c024000

I took a look at drivers/net/wireless/ipw2200.c:ipw_init_nic()

The crash happens at the memory access to look if the clock is ready yet.

Right before the following is done:

ipw_write32(priv, IPW_READ_INT_REGISTER,
            IPW_BIT_INT_HOST_SRAM_READ_INT_REGISTER);

Without this line (like in ipw2100 drivers) the driver seems to work (got connection), but that's _not_ how it's supposed to work. (and I don't know what is done here either or why it leads to a segfault)

Any ideas what may be wrong and btw., as far as I can see, this driver doesn't support master-mode, that's what the ipw2200ap driver is about.

Bye, Andreas.

comment:9 Changed 10 years ago by florian

  • Resolution set to wontfix
  • Status changed from reopened to closed

I assume it got fixed with the kernel upgrades.

comment:10 follow-up: Changed 9 years ago by bathizte

The pb still occurs on my WL-500gp / Intel Wireless Pro/2200BG : kamikaze 8.09 with ipw2200 firmware 3.1

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmq
ipw2200: Copyright(c) 2003-2006 Intel Corporation
PCI: Enabling device 0000:00:02.0 (0000 -> 0002)
PCI: Fixing up device 0000:00:02.0
PCI: Setting latency timer of device 0000:00:02.0 to 64
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
Data bus error, epc == c01564b8, ra == c015fd4c
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000d800 c0122000 c0122000
$ 4   : 81c64b20 00000024 00000001 000000fa
$ 8   : 00000000 8010ffd0 c0122024 40000000
$12   : 80280000 ffffffe0 80289588 802895a8
$16   : 81ec8800 c0172ab8 80298360 81c64000
$20   : 81c64b20 81c514c0 c0124000 c0124010
$24   : 00000001 8014141c                  
$28   : 81c88000 81c89b68 00000003 c015fd4c
Hi    : 00000001
Lo    : 18c631aa
epc   : c01564b8     Not tainted
ra    : c015fd4c Status: 1000d803    KERNEL EXL IE 
Cause : 0080001c
PrId  : 00029006 (Broadcom BCM3302)
Modules linked in: ipw2200(+) nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_state nf_conntrack_ipv4 nf_conntrack ipt_REJECT xt_TCPMSS ipt_LOG xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc crc_ccitt mac80211 cfg80211 ieee80211_crypt_ccmp ieee80211_crypt_tkip ieee80211_crypt_wep ieee80211 ieee80211_crypt michael_mic arc4 aes_generic deflate ecb cbc crypto_blkcipher crypto_hash cryptomgr crypto_algapi switch_robo switch_core diag
Process insmod (pid: 536, threadinfo=81c88000, task=81c2f4b0)
Stack : ffffffff 81f52e80 00000001 00000000 00000000 00000000 81c89c1c 81c89c53
        81c89c20 ffffffff 00000002 81c89c60 81f52e00 00000010 c00982a0 8010e0cc
        81c51400 00000000 8010da54 80058394 c01298ce c0125950 81c64b20 81c64b20
        80298360 81c64000 80200000 81c514c0 81c51400 00000000 c00982a0 c0160e90
        8010e210 c0170000 c00982a0 81c64001 81c64005 81c89c50 80298364 81c89c50
        ...
Call Trace:[<c00982a0>][<8010e0cc>][<8010da54>][<80058394>][<80200000>][<c00982a0>][<c0160e90>][<8010e210>][<c00982a0>][<80200000>][<c016a38c>][<80200000>][<80178748>][<801782fc>][<8004d1a0>][<800367a8>][<801787ac>][<c016c058>][<c016ba64>][<c00982a0>][<8011f93c>][<800c7c3c>][<8010860c>][<8013c200>][<802018fc>][<8013c698>][<8013adc8>][<80108b80>][<801083d8>][<8013c520>][<8013af48>][<80108be0>][<8013abf4>][<8013bc68>][<8013bc40>][<8013cde8>][<8011fba8>][<80023e08>][<80023de4>][<c011d058>][<8004c0c4>][<8007e47c>][<80092554>][<8000b130>]

Code: 00455021  3c0c8028  3c0b4000 <8d420000> 00461024  10460011  8d833a20  24050009  356400b0 

I'll try with a custom build of kamikaze, but it sounds bad, since it's an old old issue...

comment:11 in reply to: ↑ 10 ; follow-up: Changed 9 years ago by Bfg

I can confirm that this happen also to my router... same configuration... Kamikaze 8.09.1

comment:12 in reply to: ↑ 11 Changed 9 years ago by IvanN

Replying to Bfg:

I can confirm that this happen also to my router... same configuration... Kamikaze 8.09.1

And I can confirm also... Kamikaze 8.09.1, WL-500GP, IPW2200BG fw3.0, 3.1

comment:13 Changed 8 years ago by Gus Wirth <gwirth79@…>

It's also segfaulting on a RouterStation with trunk r19033 installed. Card is an Intel 2200BG. Tested firmware 3.0 and 3.1, kernel 2.6.30.10. Same data bus error. I'll try a debug build to see if I can narrow it down.

comment:14 Changed 8 years ago by peter

Confirmed on 19565 with 2200BG, kernel 2.6.30.10, firmware 3.1 (Asus WL-500W).

comment:15 Changed 8 years ago by crosser@…

I get the same error on Kamikaze 8.09.2, 2200BG, firmware 3.0 and 3.1.
In the hope that it got fixed in later kernels (as florian suggested), I tried 10.03-beta, and there are no ipw2100/ipw2200 modules there at all! Can this be reopened please?

comment:16 Changed 8 years ago by Eugene Crosser <crosser@…>

comment:17 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.