Modify

Opened 8 years ago

Last modified 22 months ago

#7025 reopened defect

Luci-based package list update fails

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Backfire 10.03
Component: packages Version: Trunk
Keywords: Cc:

Description

Clicking on "Update package lists" in web interface yields the following error:
Package lists updated: Error (Could not set default destination)

CLI:

root@OpenWrt:~# opkg update
Downloading /Packages.gz.
wget: not an http or ftp url: /Packages.gz
Collected errors:

  • opkg_download: Failed to download /Packages.gz, wget returned 1.

Attachments (0)

Change History (13)

comment:1 Changed 8 years ago by anonymous

Guess I should've named it: Package update fails.

comment:2 Changed 8 years ago by anonymous

RC2, not RC3

comment:3 follow-up: Changed 8 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

This is due to a broken opkg.conf

comment:4 Changed 8 years ago by nico

  • Milestone changed from Backfire 10.03-rc3 to Backfire 10.03

comment:5 in reply to: ↑ 3 Changed 8 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to jow:

This is due to a broken opkg.conf

Im using backfire 10.03 bcm-2.4 final relase on a buffalo whr-hp-54g and im getting the same error:

Clicking on "Update package lists" in web interface yields the following error: Package lists updated: Error (Could not set default destination)

From CLI:
# opkg update
Downloading http://downloads.openwrt.org/backfire/10.03/brcm-2.4/packages/Packages.gz.
wget: bad address 'downloads.openwrt.org'
Collected errors:

comment:6 Changed 8 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

"wget: bad address 'downloads.openwrt.org'" - this is a connection or DNS issue, it has nothing to do with the web interface.

comment:7 Changed 7 years ago by Jorge Arias

You need to add a DNS server on interface, bad address 'downloads.openwrt.org'" not resolve the URL...

comment:8 Changed 3 years ago by pedro

i have the same problem and the dns resolve the url, so i have try do download it mannuel but ist say the same

comment:9 Changed 3 years ago by anonymous

Check if the URL needs a packages/packages. Change that in /etc/opkg.conf if needed.

comment:10 Changed 3 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:11 Changed 3 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:12 Changed 22 months ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

why wasn't this solved? I still have this problem

comment:13 Changed 22 months ago by anonymous

It was marked closed because no evidence exists for this being a bug in the web UI or package manager, versus someone having misconfigured their package feeds.

(OpenWRT builtin) wget reporting "bad address", for example is caused by not being able to resolve an address - which, indeed, points to a DNS or similar misconfiguration on the router, not a problem with OpenWRT.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.