Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#7001 closed defect (fixed)

luci doesn't enable upnp

Reported by: RvD Owned by: jow
Priority: normal Milestone: Backfire 10.03.1
Component: luci Version: Backfire 10.03 RC3
Keywords: upnp brcm47xx Cc:

Description

Steps to reproduce:

  1. install luci-app-upnp
  1. reboot
  1. enable upnp in luci – nothing happens in output
  1. reboot
  1. upnp seems enabled in luci – upnp is neither running nor enabled

Steps to fix it in shell:

  1. /etc/init.d/miniupnpd enabled && echo ok – turns up empty
  1. /etc/init.d/miniupnpd enable
  1. /etc/init.d/miniupnpd enabled && echo ok – turns up ok
  1. /etc/init.d/miniupnpd start – upnp is running
  1. reboot – upnp is running

Attachments (0)

Change History (14)

comment:1 Changed 8 years ago by thepeople

  • Milestone changed from Backfire 10.03-rc2 to Backfire 10.03
  • Owner set to jow
  • Status changed from new to assigned

comment:2 Changed 8 years ago by jow

  • Resolution set to obsolete
  • Status changed from assigned to closed

Backfire RC2 and later has a menu for managing init scripts in a generic way (luci-app-initmgr). Init scripts for opkg-installed are not enabled by design and we stopped to work around that in the per-component config pages.

comment:3 Changed 8 years ago by RvD

  • Resolution obsolete deleted
  • Status changed from closed to reopened

luci-app-initmgr works as it's supposed to in RC2.

Just the checkbox in luci-app-upnp to enable upnp still doesn't work. :(

comment:4 Changed 8 years ago by thepeople

  • Status changed from reopened to assigned

comment:5 Changed 8 years ago by RvD

Same for RC3.

comment:6 Changed 8 years ago by anonymous

I've confirmed this. The luci-app-inimgr is starting miniupnp properly, however luci-app-upnp is not enabling it (via the enable checkbox). Upon setting the "enable" checkbox in luci-app-upnp, the following should be executed:

/etc/init.d/miniupnpd enable

Should be a simple fix.

comment:7 Changed 8 years ago by nico

  • Version changed from backfire 10.03 RC1 to Backfire 10.03 RC3

comment:8 Changed 8 years ago by anonymous

4 months old, still happening in 10.03.

comment:9 Changed 7 years ago by starix

Confirmed for Backfire 10.03.1-RC3

comment:10 Changed 7 years ago by anonymous

This applies to QoS also, at least.

comment:11 Changed 7 years ago by Frex

RC4 too. miniupnpnd has to be enabled manually either in the initscript section or from the shell.

comment:12 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from assigned to closed

Should be fixed in RC5

comment:13 Changed 5 years ago by anonymous

works in 12.09-rc1

comment:14 Changed 4 years ago by glyph@…

I just installed luci-app-upnp on 12.09-final and I don't see any UI show up. I've looked everywhere I can think of. What tab is it supposed to be showing up in?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.