Modify

Opened 8 years ago

Last modified 4 years ago

#6928 new defect

Permissions change in Image/mkfs/prepare/default causing troubles with sudo, authorized_keys and non-root ping

Reported by: Andre Nazario <samoied@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

I tried to use sudo in openwrt, but when preparing image, script Image/mkfs/prepare/default, located in include/image.mk, removes suid bit from /bin/sudo. Without this, sudo is unusable.
Other problem with this script is with /etc/dropbear/authorized_keys, and non-root operations on busybox, like ping.
I've attached a simple path that solved my problems.

Attachments (1)

150-permissions-changes.patch (814 bytes) - added by Andre Nazario <samoied@…> 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Andre Nazario <samoied@…>

comment:1 Changed 8 years ago by nico

  • Milestone changed from Backfire 10.03 to Kamikaze

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.