Modify

Opened 8 years ago

Closed 8 years ago

#6851 closed defect (fixed)

madwifi doesn't detect wlan device on tmd sd1-s

Reported by: anonymous Owned by: florian
Priority: high Milestone: Backfire 10.03.1
Component: packages Version: Backfire 10.03 Beta
Keywords: Cc:

Description

If I try openwrt backfire-beta on tmd sd1-a (au1500 platform) madwifi doesn't detect the wifi-devices. Nothing in /etc/config/wireless. Nothing in /proc/sys/dev/. With kamikaze everything is fine.

Dmesg with madwifi: http://pastebin.com/GZgdHUrz
Dmesg with ath5k: http://pastebin.com/NxPKp5Ss
lspci: http://pastebin.com/BE1STxnW

Attachments (0)

Change History (14)

comment:1 Changed 8 years ago by jow

According to the reporter, the wifi chipset in question is AR 5005G

comment:2 Changed 8 years ago by thepeople

  • Owner changed from developers to nbd
  • Status changed from new to assigned

comment:3 Changed 8 years ago by anonymous

Cpuinfo: http://pastebin.com/CjyEw8zP

I think the problem is more about proper pci bus detection. don't know...

comment:4 Changed 8 years ago by br1@…

i can imagine that they (4g) messed around with the PCI configuration... is this a miniPCI card at all?

comment:5 Changed 8 years ago by anonymous

Yes it is on the regular minipci, not on the extentionboard. Although it is properly detected in kamikaze :)

Problem seems to be connected to kernel. Flashed kamikaze kernel and backfire filesystem and got a running lspi and proper /proc/bus/pci configuration.

comment:6 Changed 8 years ago by br1@…

same problem happens on the mtx-1 (MeshCube), so i'm pretty sure the problem is related to PCI configuration (idsel from what the lspci output looks like).

on the cube - dmesg: http://pastebin.com/e0Vqhxsf, cat /proc/bus/pci/devices: http://pastebin.com/ZQ50MfTz

comment:7 Changed 8 years ago by nbd

  • Owner changed from nbd to florian

comment:8 Changed 8 years ago by br1@…

i think it has to do with PCI being in 36-bit address space. check out this patch:

http://www.linux-mips.org/git?p=linux.git;a=commit;h=60ec6571c5072cdea9e518d1dac8147b85ca93a2

without it we got: "pci 0000:00:00.0: can't handle 64-bit BAR"

unfortunately this patch alone is not enough, and PCI on au1000 is still broken...

comment:9 Changed 8 years ago by anonymous

Thanks for working on this!

Applied patch. Now I get:

pci 0000:00:00.0: reg 10 64bit mmio: [0x200000000-0x3ffffffff]

But as you mentioned pci is still broken :)
Code fails here:

sz = pci_size(l, sz, mask);

if (!sz)

goto fail;

res->start = l;
res->end = l + sz;

because of pci_size and pci_size fails because of strange values for l, sz and mask I think. l and sz are set by this peace of code:

pci_read_config_dword(dev, pos, &l);
pci_write_config_dword(dev, pos, mask);
pci_read_config_dword(dev, pos, &sz);
pci_write_config_dword(dev, pos, l);

So I think pci_read_config is broken but that's the end for me as kernel noob :) Some background information would be super cool! Thanks again for working on this bug.

comment:10 Changed 8 years ago by florian

I was able to reproduce the issue on my MTX-1 will bisect which changes caused that.

comment:11 Changed 8 years ago by Wellenreiter

No solution, yet?! :(

comment:12 Changed 8 years ago by florian

There is one, I am just not sure if we cannot find a better solution. Will commit the patch tonight.

comment:13 Changed 8 years ago by Wellenreiter

@florian ... would be nice to twit it @datenmine if its working :) thanx!

comment:14 Changed 8 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r22033

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.