Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#6816 closed defect (fixed)

glib2 fails to compile when using eglibc because of missing gettext support

Reported by: mirko Owned by: lars
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Kamikaze trunk
Keywords: Cc:

Description

[..]
checking whether we are using the GNU C Library 2.1 or newer... yes
checking Whether to cache iconv descriptors... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... no
configure: error:
*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. (http://www.gnu.org/software/gettext/gettext.html

make[3]: *** [/home/openwrt/openwrt.svn.git/trunk/build_dir/host/glib-2.22.2/.configured] Error 1
make[3]: Leaving directory `/home/openwrt/openwrt.svn.git/packages/libs/glib2'
make[2]: *** [package/feeds/packages/glib2/host/compile] Error 2
make[2]: Leaving directory `/home/openwrt/openwrt.svn.git/trunk'
make[1]: *** [/home/openwrt/openwrt.svn.git/trunk/staging_dir/target-i386_eglibc-2.8/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/openwrt/openwrt.svn.git/trunk'
make: *** [world] Error 2

I wonder why this is no problem when using uclibc.

Attachments (1)

config.log (36.0 KB) - added by blackmole <openwrt@…> 8 years ago.
my config.log

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by lars

  • Owner changed from developers to lars
  • Status changed from new to assigned

please attach config.log

Changed 8 years ago by blackmole <openwrt@…>

my config.log

comment:2 Changed 8 years ago by blackmole <openwrt@…>

Duplicate of /ticket/3033.html
So just install gettext on the compiling machine, maybe this should be added on http://nuwiki.openwrt.org/doc/howto/build?s[]=svn

comment:3 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

gettext has been added as a host tool

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.