Modify

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#6796 closed defect (wontfix)

static ethernet and pppoe did not work on the same device

Reported by: johann-nikolaus.andreae@… Owned by: developers
Priority: response-needed Milestone: Backfire 10.03.1
Component: packages Version: Kamikaze 8.09
Keywords: Cc:

Description

I use Kamikaze 8.09.2 an have the following config:

config 'switch' 'eth0'

option 'vlan0' '0 1 2 3 4 5*'

config 'interface' 'loopback'

option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'

config 'interface' 'lan'

option 'ifname' 'eth0.0'
option 'proto' 'static'
option 'netmask' '255.255.255.0'
option 'ipaddr' '192.168.96.1'
option 'defaultroute' '0'
option 'peerdns' '0'

config 'interface' 'wan'

option 'proto' 'pppoe'
option 'password' '1234567'
option 'keepalive' '10'
option 'username' '...0001@…'
option 'ifname' 'eth0.0'

If i boot the router they did not set up the pppoe konnection.
I can manualy connect with ifup wan.

I have try it with extra init scrips they only call ifup wan. but in this case i have mutible ppp running and lan is not set up anny more.
I did not get both to work.

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by thepeople

  • Milestone changed from Kamikaze to Backfire 10.03
  • Version changed from Kamikaze 8.09 to Backfire 10.03 Beta

Can you try the 10.03 beta and see if this still applies?

comment:2 Changed 8 years ago by thepeople

  • Version changed from Backfire 10.03 Beta to Kamikaze 8.09

Didn't want to change the reported version.

comment:3 Changed 8 years ago by johann-nikolaus.andreae@…

yes i can verify this problem also with 10.3 beta.
I tested i in VirtualBox capture the network treffic wit wireshark.
I see no until i call ifup wan.

comment:4 Changed 8 years ago by jeremy@…

I'm having the same problem. A big part of the problem is that "ifup wan" calls "ifdown wan", and thus, clobbers the lan interface that is already associated with the eth0.0 device.

I'm of the opinion that the philosophy OpenWrt has of "1 PPPoE interface" == "1 physical LAN interface" is completely flawed and nonsensical.

comment:5 Changed 7 years ago by nico

  • Priority changed from high to response-needed

Can you confirm this issue is still present in 10.0.3-rc1 ?

comment:6 Changed 7 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

This is actually by design, multiple networks cannot share one interface (yet).
One possible workaround is setting up a MAC VLAN with the PPPoE interface tied to it.
Spawn the macvlan interface from rc.local and hotplug will kick the pppd into operation.

comment:7 Changed 7 years ago by jeremy@…

This is actually by design

Well that’s convenient, isn’t it. Now I guess the problem doesn’t need to be fixed.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.