Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#6706 closed defect (fixed)

mac80211 led strobing on ath9k

Reported by: jklee Owned by: nbd
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: mac80211 led strobing ath9k Cc: jonathan.klee@…

Description

I have tried to get a led to strobe using netdev but without any success :

echo "netdev" > /sys/class/leds/kikoo:led0/trigger
echo wlan1 > /sys/class/leds/kikoo:led0/device_name
echo "link tx rx" > /sys/class/leds/kikoo:led0/mode
echo 1 > /sys/class/leds/kikoo:led0/brightness

I have also tried to use phy0rx but it didn't work either.

none nand-disk timer heartbeat default-on [netdev] phy0rx phy0tx phy0assoc phy0radio

Get a led to blink is OK but "netdev" doesn't work.

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by anonymous

Did you compiled netdev into image?

comment:2 Changed 8 years ago by anonymous

Use /etc/config/system to configure the LEDs:

http://wiki.openwrt.org/doc/uci/system

comment:3 Changed 8 years ago by anonymous

Yes, I had already compiled netdev into the image. And I also tried with the UCI system file but without any success.

comment:4 Changed 8 years ago by thepeople

  • Owner changed from developers to nbd
  • Status changed from new to assigned

comment:5 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

Latest version enables a proper LED blink trigger by default.

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.