Modify

Opened 8 years ago

Closed 3 years ago

#6601 closed defect (moved_to_github)

"This Perl not built to support threads"

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

i had:

  • perl - 5.10.0-2
  • perlbase-base - 5.10.0-2
  • perlbase-threads - 5.10.0-2

but when i try to run slimrat i have this error message.

Attachments (0)

Change History (9)

comment:1 Changed 5 years ago by florian

  • Resolution set to too_vague
  • Status changed from new to closed

comment:2 Changed 5 years ago by bugs@…

What about this is too vague??

I have the same problem, if try to execute a perl script which uses threads "use threads;"

There is a package perlbase-threads, which suggests threads-support for perl

If you need futher details, please mail me or write a comment

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:4 Changed 3 years ago by anonymous

Still the problem exists in Barrier Breaker 14.07 with Perl v5.20

comment:5 follow-up: Changed 3 years ago by anonymous

Hello.
It was possible to solve this problem?
I use this perl -
http://downloads.openwrt.org/barrier_breaker/14.07/ramips/rt305x/packages/packages/perl_5.20.0-6_ramips_24kec.ipk
Please add to this package support threads
(((

comment:6 Changed 3 years ago by i1v1s@…

Hello.
It was possible to solve this problem?
I use this perl -
http://downloads.openwrt.org/barrier_breaker/14.07/ramips/rt305x/packages/packages/perl_5.20.0-6_ramips_24kec.ipk
Please add to this package support threads
(((

comment:7 in reply to: ↑ 5 Changed 3 years ago by anonymous

  • Resolution too_vague deleted
  • Status changed from closed to reopened

comment:8 Changed 3 years ago by Naoir

Threading support has been merged into Chaos Calmer/trunk, see https://github.com/openwrt/packages/pull/854.

Please note that a threading-enabled perl using uclibc lacks crypt() and anything related. If your application depends on that functionality, you'll have to switch to a glibc build for the time being.

Also note that Barrier Breaker/14.07 will not receive threading support.

comment:9 Changed 3 years ago by nbd

  • Resolution set to moved_to_github
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.