Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#6565 closed defect (fixed)

latest builds unconditionally assigns 192.168.1.1 to eth0 regardless of network configuration settings

Reported by: johnc60@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Kamikaze 8.09
Keywords: Cc:

Description

On the latest builds (of Atheros, at least) the IP address for interface eth0 is unconditionally set to 192.168.1.1/24 despite having a valid user defined network configuration. IP addressing should use the network configuration file except for failsafe mode. This was working correctly in previous builds (r15888 and 8.09.1) and is broken in the current trunk and in 8.09.2.

This defect renders the router unusable because the LAN side is unreachable.

In the following example, IP address 192.168.1.230 should be assigned to interface br-lan. However, on interface eth0, the IP address of 192.168.1.1 is also assigned. This double assignment is also reflected in the routing table. The network config file is also included.

ifconfig information:

br-lan Link encap:Ethernet HWaddr 00:1D:6A:DC:F8:07

inet addr:192.168.1.230 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:16030 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3310650 (3.1 MiB) TX bytes:0 (0.0 B)

br-wan Link encap:Ethernet HWaddr 00:1D:6A:DC:F8:08

inet addr:x.x.x.x Bcast:66.159.220.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:3024 (2.9 KiB)

eth0 Link encap:Ethernet HWaddr 00:1D:6A:DC:F8:08

inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:16054 errors:0 dropped:0 overruns:0 frame:0
TX packets:73 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3601741 (3.4 MiB) TX bytes:4355 (4.2 KiB)
Interrupt:4 Base address:0x1000

eth0.1 Link encap:Ethernet HWaddr 00:1D:6A:DC:F8:08

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:16041 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3375608 (3.2 MiB) TX bytes:0 (0.0 B)

eth0.2 Link encap:Ethernet HWaddr 00:1D:6A:DC:F8:08

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:3312 (3.2 KiB)

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2304 (2.2 KiB) TX bytes:2304 (2.2 KiB)

route information:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
x.x.x.x 0.0.0.0 255.255.255.0 U 0 0 0 br-wan
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
0.0.0.0 x.x.x.x 0.0.0.0 UG 0 0 0 br-wan

Network configuration file:

config switch eth0

option reset 1
option enable_vlan 1

config switch_vlan eth0_1

option device eth0
option vlan 1
option ports '0 1 2 3 5t'

config switch_vlan eth0_2

option device eth0
option vlan 2
option ports '4 5t'

config interface loopback

option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan

option ifname eth0.1
option proto static
option ipaddr 192.168.1.230
option netmask 255.255.255.0
option type bridge
option mtu 1500

config interface wan

option ifname eth0.2
option proto static
option ipaddr x.x.x.x
option netmask 255.255.255.0
option gateway x.x.x.x
option dns "208.67.222.222 208.67.220.220"
option type bridge
option mtu 1500

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by Daniel Dickinson <cshore@…>

I had this in #6074, however it's working now, so I'm wondering if it's an intermittent uci-defaults bug (this is in trunk)

comment:2 Changed 8 years ago by jow

Shouldn't this be fixed by /changeset/17597.html ?

comment:3 Changed 8 years ago by anonymous

I'm have the same issue with todays trunk. Im compiling for Routerstation Pro. ( assigns 192.168.1.1 to eth0 regardless)

comment:4 Changed 7 years ago by anonymous

Ended up disabling image configuration for now

comment:5 Changed 7 years ago by cshore

  • Resolution set to fixed
  • Status changed from new to closed

This has been working for some time. Need a new report if it shows up again.

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.