Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6507 closed defect (wontfix)

After machine boot, abnormal 5 minutes sleep of olsrd process

Reported by: clownix@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Kamikaze 8.09
Keywords: select olsrd delay at boot Cc:

Description

Problem on 8.09.2: Just after machine boot, when olsr is launched, it takes 5 minutes before olsr begins sending hellos.

Probable cause: a strange negative value visible with the strace command:

strace /usr/sbin/olsrd -d 9

times({tms_utime=0, tms_stime=0, tms_cutime=0, tms_cstime=0}) = -24111
nanosleep({0, 50000000}, {0, 0}) = 0
times({tms_utime=0, tms_stime=0, tms_cutime=0, tms_cstime=0}) = -24102
select(8, [7], NULL, NULL, {0, 0}) = 0 (Timeout)
times({tms_utime=0, tms_stime=0, tms_cutime=0, tms_cstime=0}) = -24102

The -24111 decrements to 0 in 5 minutes time and then things seem to begin moving normally.

You can reproduce the above problem on your PC by following the steps:

1 Download the file: http://cloonix.net/cloonix_labs_4_debug.tar.gz

2 Untar in your /home/yourname directory and

"cd /home/yourname/cloonix_labs_4_debug"

3 ./start_cloonix_net

4 ./graph

5 Right-click on the canvas (inside the Cloonix window) to access to a menu, go to:

"Load Topo"

"virtual_platform_configs"

"olsr_demo_openwrt_uml" (or kvm)

"topology"

6 Double-click on ROUTER1, do "ps -ef" and kill the olsrd process

7 Call "strace /usr/sbin/olsrd -d 9" you get 5 minutes of:

times({tms_utime=0, tms_stime=0, tms_cutime=0, tms_cstime=0}) = -21396
nanosleep({0, 50000000}, {0, 0}) = 0
times({tms_utime=0, tms_stime=0, tms_cutime=0, tms_cstime=0}) = -21391
select(8, [7], NULL, NULL, {0, 0}) = 0 (Timeout)

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by jow

Maybe related to a timewarp caused by ntpclient spawned later?

comment:2 Changed 8 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

Ticket timeout - this is most certainly a time warp and needs to be addressed in olsrd itself. A possible workaround is to restart olsrd after the system time is synced.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.