Modify

Opened 12 years ago

Closed 11 years ago

#650 closed defect (fixed)

1.0r6 whiterussian: ipkg remove hangs

Reported by: leo <mleina1@…> Owned by: developers
Priority: normal Milestone: 0.9/rc6
Component: base system Version:
Keywords: Cc:

Description

I've been seeing this problem with ipkg 0.99.149 (compiled) on Whiterussian svn current. ipkg remove hangs after running postrm. This is regardless of what package is removed and whether the package has a postrm script or not. ipkg will catch a ctrl-c at this point and clean up properly.

I've tried several ipkg versions up until current (0.99.163) with no luck. It seems to hang at remove_maintainer_scripts_except_postrm() in ipkg on a call to glob().

strace spits out this at the hang point:
stat("usr/lib/ipkg/info", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
open("
usr/lib/ipkg/info", O_RDONLY) = 3
fcntl(3, F_SETFD, FD_CLOEXEC) = 0
getdents(3, /* d_reclen == 0, problem here ** 1 entries */, 3933) = 1392
lseek(3, 16777216, SEEK_SET) = -1 EISDIR (Is a directory)

Can someone confirm this bug? Does this sound like a bug in ipkg or in uClibc's glob function?

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by leo <mleina1@…>

More information:
It appears that this bug is caused by mini_fo being enabled. Apparently mini_fo introduces some incompatibility with uClibc's glob() function (tested on uClibc 0.9.28 as well, gives a segfault rather than a hang).

comment:2 Changed 12 years ago by netprince

I can confirm this problem, happening for me too...

comment:3 Changed 11 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

mini_fo was disabled in [4872] due to numerous issues with glob() and other things.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.