Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6479 closed defect (duplicate)

broken WPA2/PSK authentication on brcm47xx

Reported by: crick <mail@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: wpa2 wifi brcm47xx Cc:

Description

Somewhere after revision 19019 WPA2/PSK authentication was broken on brcm47xx platform. WIFI works fine without encryption. But when I try to connect to WPA2/PSK protocol, the password is not accepted. My Device is asus wl500gp. At revision 19019 everything works with the same password.
Sorry for bad English of Goggle.

Attachments (2)

console.log (3.6 KB) - added by Amain <amain@…> 8 years ago.
debug output hostapd and console log
hostapd.conf (223 bytes) - added by Amain <amain@…> 8 years ago.
hostapd configuration file

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by Amain <amain@…>

I can confirm this. Checked out r19080 and indeed when using wireless WEP or no encryption, there is no problem. Switching to WPA however triggers a Fatal Exception. Reverted to r19019 and WPA works just fine ( unfortunately, my wireless connection drops every couple of seconds and then is re-established again )

Using kernel: 2.6.30.10
Rootfs : Debian MIPSEL
Hostapd : 0.6.9

Changed 8 years ago by Amain <amain@…>

debug output hostapd and console log

Changed 8 years ago by Amain <amain@…>

hostapd configuration file

comment:2 Changed 8 years ago by Amain <amain@…>

Forgot to mention: using an Asus WL-500g DeLuxe ( brcm47xx, b43 ).

comment:3 Changed 8 years ago by anonymous

see also ticket #6473.

comment:4 Changed 8 years ago by hauke

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #6473.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.