Modify

Opened 12 years ago

Closed 11 years ago

#647 closed defect (fixed)

openswan: Pluto crashes out with an init error

Reported by: ijw.openwrt.trac@… Owned by: florian
Priority: normal Milestone: 0.9/rc6
Component: packages Version:
Keywords: Cc:

Description

I get the "mpz_init_set_str() failed in init_crypto()" error from pluto/crypto.c:init_crypto(). I don't know why. It may be an actual bug or a configuration problem on my system.

I've tried this with both shared secrets and RSA, but it happens in both cases. An example config file is available on request (but I don't have it here to attach to this bug); in particular, it happens with the ipsec.secrets and ipsec.conf from the Wiki page about running ipsec.

wrt54g v2 hardware.

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

Can you have a try at the following package : http://downloads.openwrt.org/people/florian/ipsec/

comment:2 Changed 11 years ago by florian

  • Milestone set to 0.9/rc6

comment:3 Changed 11 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

Should be fixed with the new version. Please reopen if the problem persists.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.