Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#6434 closed defect (wontfix)

Routerboard 411ar locks up in adhoc mode

Reported by: abates@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

My RB411ar (on board atheros wireless) locks up if I put the on-board wireless into adhoc mode.

Attachments (2)

ath_errors.txt (1.3 KB) - added by abates@… 8 years ago.
Error output from console
ath_console.txt (4.1 KB) - added by abates@… 8 years ago.
Kernel boot from console

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by abates@…

Error output from console

Changed 8 years ago by abates@…

Kernel boot from console

comment:1 follow-up: Changed 8 years ago by abates@…

I wonder if this is an issue with madwifi.... The wireless card is an Atheros AR2417 (according to Mikrotik specifications) and lspci shows the chipset an AR5007g:

root@OpenWrt:/# lspci -s 0000:00:11.00 -vv
00:11.0 Ethernet controller: Atheros Communications Inc. AR5007G Wireless Network Adapter (rev 01)
        Subsystem: Atheros Communications Inc. Device 2055
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 96 (2500ns min, 7000ns max), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 50
        Region 0: Memory at 10000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: ath_pci

root@OpenWrt:/#

It seems the issue is not only related to ad-hoc mode but whenever the interface is enabled. If wifi0 is disabled, however, the system never locks up (even with the kernel modules inserted).

-Andrew

comment:2 Changed 8 years ago by abates@…

Adding an AR5212 card into the available slot and enabling ath0/wifi1 (wifi0 still disabled) seems to work fine without the system locking up. Perhaps this is an interrupt related problem.

-Andrew

comment:3 Changed 8 years ago by mitar

Any luck with this? I would like to use both interfaces so I am wondering if it works (before I buy this Routerboard).

comment:4 Changed 8 years ago by mitar

I got this board for testing and there are really some problems. I was playing with it and I got this kernel oop trying to use built-in WiFi card (AR2417):

Unhandled kernel unaligned access[#1]:
Cpu 0
$ 0   : 00000000 80460000 00000000 00000000
$ 4   : 000000e1 00000000 27be00c0 00000001
$ 8   : 1800d400 1000001e 800d8064 fffffff8
$12   : 75742720 83919e48 00000000 00480000
$16   : 838dfd90 8e3200e0 70703a20 00000000
$20   : 70703a54 00000000 838e8108 00000005
$24   : 0047d300 2ab196f0                  
$28   : 838de000 838dfd68 00000001 80060820
Hi    : 00000028
Lo    : 83f71000
epc   : 8007054c 0x8007054c
    Tainted: P          
ra    : 80060820 0x80060820
Status: 1800d402    KERNEL EXL 
Cause : 00800010
BadVA : 10000c2a
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: ath_pci ath_hal(P) /(PF)Unhandled kernel unaligned access[#2]:
Cpu 0
$ 0   : 00000000 80460000 00000000 00000000
$ 4   : 000000e1 00000000 2f0028a3 f1730000
$ 8   : 1800d400 1000001e 00000400 80465c5c
$12   : 000000cd 00000012 00000000 00480000
$16   : 838df920 8e3200e0 80274920 00000000
$20   : 70703a54 00000000 838e8108 00000005
$24   : 00000008 8019b1a4                  
$28   : 838de000 838df8f8 00000001 80060820
Hi    : 00000000
Lo    : f1730000
epc   : 8007054c 0x8007054c
    Tainted: P          
ra    : 80060820 0x80060820
Status: 1800d402    KERNEL EXL 
Cause : 40808410
BadVA : 10000c2a
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: ath_pci ath_hal(P) /(PF)Unhandled kernel unaligned access[#3]:
Cpu 0
$ 0   : 00000000 80460000 00000000 00000000
$ 4   : 000000e1 00000000 2f0028a3 f1730000
$ 8   : 1800d400 1000001e 00000400 80465c5c
$12   : 000000cd 00000012 00000000 00480000
$16   : 838df4b0 8e3200e0 80274920 00000000
$20   : 70703a54 00000000 838e8108 00000005
$24   : 00000008 8019b1a4                  
$28   : 838de000 838df488 00000001 80060820
Hi    : 00000000
Lo    : f1730000
epc   : 8007054c 0x8007054c
    Tainted: P          
ra    : 80060820 0x80060820
Status: 1800d402    KERNEL EXL 
Cause : 40808410
BadVA : 10000c2a
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: ath_pci ath_hal(P) /(PF)Unhandled kernel unaligned access[#4]:
Cpu 0
$ 0   : 00000000 80460000 00000000 00000000
$ 4   : 000000e1 00000000 2f0028a3 f1730000
$ 8   : 1800d400 1000001e 00000400 80465c5c
$12   : 000000cd 00000012 00000000 00480000
$16   : 838df040 8e3200e0 80274920 00000000
$20   : 70703a54 00000000 838e8108 00000005
$24   : 00000008 8019b1a4                  
$28   : 838de000 838df018 00000001 80060820
Hi    : 00000000
Lo    : f1730000
epc   : 8007054c 0x8007054c
    Tainted: P          
ra    : 80060820 0x80060820
Status: 1800d402    KERNEL EXL 
Cause : 40808410
BadVA : 10000c2a
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: ath_pci ath_hal(P) /(PF)Unhandled kernel unaligned access[#5]:
Cpu 0
$ 0   : 00000000 80460000 00000000 00000000
$ 4   : 000000e1 00000000 2f0028a3 f1730000
$ 8   : 1800d400 1000001e 00000400 80465c5c
$12   : 000000cd 00000012 00000000 00480000
$16   : 838debd0 8e3200e0 80274920 00000000
$20   : 70703a54 00000000 838e8108 00000005
$24   : 00000008 8019b1a4                  
$28   : 838de000 838deba8 00000001 80060820
Hi    : 00000000
Lo    : f1730000
epc   : 8007054c 0x8007054c
    Tainted: P          
ra    : 80060820 0x80060820
Status: 1800d402    KERNEL EXL 
Cause : 40808410
BadVA : 10000c2a
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: ath_pci ath_hal(P) /(PF)Unhandled kernel unaligned access[#6]:
Cpu 0
$ 0   : 00000000 80460000 00000000 00000000
$ 4   : 000000e1 00000000 2f0028a3 f1730000
$ 8   : 1800d400 1000001e 00000400 80465c5c
$12   : 000000cd 00000012 00000000 00480000
$16   : 838de760 8e3200e0 80274920 00000000
$20   : 70703a54 00000000 838e8108 00000005
$24   : 00000008 8019b1a4                  
$28   : 838de000 838de738 00000001 80060820
Hi    : 00000000
Lo    : f1730000
epc   : 8007054c 0x8007054c
    Tainted: P          
ra    : 80060820 0x80060820
Status: 1800d402    KERNEL EXL 
Cause : 40808410
BadVA : 10000c2a
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: ath_pci ath_hal(P) /(PF)Unhandled kernel unaligned access[#7]:
Cpu 0
$ 0   : 00000000 80460000 00000000 00000000
$ 4   : 000000e1 00000000 2f0028a3 f1730000
$ 8   : 1800d400 1000001e 00000400 80465c5c
$12   : 000000cd 00000012 00000000 00480000
$16   : 838de2f0 8e3200e0 80274920 00000000
$20   : 70703a54 00000000 838e8108 00000005
$24   : 00000008 8019b1a4                  
$28   : 838de000 838de2c8 00000001 80060820
Hi    : 00000000
Lo    : f1730000
epc   : 8007054c 0x8007054c
    Tainted: P          
ra    : 80060820 0x80060820
Status: 1800d402    KERNEL EXL 
Cause : 40808410
BadVA : 10000c2a
PrId  : 00019374 (MIPS 24Kc)
Modules linked in: ath_pci ath_hal(P) /(PF)/[#8]:
Cpu 0
$ 0   :

comment:5 Changed 8 years ago by mitar

More errors:

PCI error 1 at PCI addr 0x10017820
Data bus error, epc == 8016adac, ra == 8008f50c
Oops[#1]:
Cpu 0
$ 0   : 00000000 00000001 00000000 8025af40
$ 4   : 8025a3b0 8025bad0 80072a20 00000001
$ 8   : 1800d400 1000001e 00000020 0000001e
$12   : 802b9ab8 81006058 0000000b 802af9fc
$16   : 80072a20 94820024 deadc0de ac620010
$20   : 0c02096c 00000000 83e41f58 7fbdb36c
$24   : 00000001 80073ec0        /        /
$28   : 83e40000 83e41e68 7fbdb198 8008f50c

Seems as a memory corruption?

comment:6 Changed 8 years ago by mitar

PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034
PCI error 1 at PCI addr 0x10c20034

comment:7 Changed 8 years ago by mitar

ath5k also does not work properly with this built-in WiFi chipset. I use it for ad-hoc and connection simply is not stable. It works, it does not crash, but the connection to other nodes just fails from time to time and in general it is more down than up.

comment:8 in reply to: ↑ 1 Changed 7 years ago by lgentili@…

[]Replying to abates@…:

I wonder if this is an issue with madwifi.... The wireless card is an Atheros AR2417 (according to Mikrotik specifications) and lspci shows the chipset an AR5007g:

root@OpenWrt:/# lspci -s 0000:00:11.00 -vv
00:11.0 Ethernet controller: Atheros Communications Inc. AR5007G Wireless Network Adapter (rev 01)
        Subsystem: Atheros Communications Inc. Device 2055
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 96 (2500ns min, 7000ns max), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 50
        Region 0: Memory at 10000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=2 PME-
        Kernel driver in use: ath_pci

root@OpenWrt:/#

It seems the issue is not only related to ad-hoc mode but whenever the interface is enabled. If wifi0 is disabled, however, the system never locks up (even with the kernel modules inserted).

-Andrew

I'm experiencing the same problem, but my board is a Routerboard 411UAHR and I've only tested it in AP mode.

I've tried:

  • 2 boards.
  • Backfire's images, Also, built from Trunk.
  • Initramfs and Nand.

After a Client connection (W7 or Ubuntu 10.04), the board crash randomly. sometimes in 5 secs, others after a couple of minutes.

Results are kind of unexpected (Looks like memory corruption), Sometimes it reset itself and other I got this:

root@OpenWrt:/# Kernel unaligned instruction access[#1]:                        
Cpu 0                                                                           
$ 0   : 00000000 80300000 0d0a422a 00010000                                     
$ 4   : 83b14000 000000c0 00000000 00000000                                     
$ 8   : 1000dc00 1000001f 00000000 83972000

Or this:

root@OpenWrt:/# Kernel bug detected[#1]:                                        
Cpu 0                                                                           
$ 0   : 00000000 80300000 d7804fec 00041456                                     
$ 4   : 83a1e840 801d2f9c 0000063c 00000061                                     
$ 8   : d7804fec ffff9e0e 7a0e30d8 66c4773b                                     
$12   : 0000003e 0000007f 00019773 802ca364                                     
$16   : 83a1e840 8386cac0 00000061 8386c800                                     
$20   : 00000310 00000000 8386cad0 8386c800                                     
$24   : 00000000 80071854

Is there anyone that have used the RB411Rxx's built-in radio (AR2417) successfuly?

Thanks in advance,

Leandro

comment:9 Changed 7 years ago by lgentili@…

Fixed!

Indeed, the problem is in madwifi drivers for the atheos chip ar2417.

Solution: Replace madwifi by ath5k drivers.

Leandro

comment:10 Changed 7 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

Since madwifi is no longer being developed, I replaced the madwifi profile with an ath5k profile in ar71xx, r26626.

comment:11 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.