Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6433 closed defect (duplicate)

Asterisk 1.6 does not build on Trunk

Reported by: marca56@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: asterisk Cc:

Description

mkdir -p /Users/marca56/openwrt/build_dir/target-mips_uClibc-0.9.30.1/asterisk-1.6.2.0-rc6/ipkg-install/usr/lib/asterisk/agi-bin
for x in agi-test.agi eagi-test eagi-sphinx-test jukebox.agi; do /sw/bin/ginstall -c -m 755 $x /Users/marca56/openwrt/build_dir/target-mips_uClibc-0.9.30.1/asterisk-1.6.2.0-rc6/ipkg-install/usr/lib/asterisk/agi-bin ; done
Installing modules from channels...
Installing modules from pbx...
Installing modules from apps...
Installing modules from codecs...
Installing modules from formats...
Installing modules from cdr...
Installing modules from bridges...
Installing modules from funcs...
Installing modules from tests...
buildinfo.c:26:32: error: asterisk/buildinfo.h: No such file or directory
buildinfo.c:27:28: error: asterisk/build.h: No such file or directory
buildinfo.c:29: error: 'BUILD_HOSTNAME' undeclared here (not in a function)
buildinfo.c:30: error: 'BUILD_KERNEL' undeclared here (not in a function)
buildinfo.c:31: error: 'BUILD_MACHINE' undeclared here (not in a function)
buildinfo.c:32: error: 'BUILD_OS' undeclared here (not in a function)
buildinfo.c:33: error: 'BUILD_DATE' undeclared here (not in a function)
buildinfo.c:34: error: 'BUILD_USER' undeclared here (not in a function)
make[5]: * [asterisk] Error 1
make[4]:
* [main-install] Error 2
make[3]: * /Users/marca56/openwrt/build_dir/target-mips_uClibc-0.9.30.1/asterisk-1.6.2.0-rc6/.built Error 2
make[2]:
* [package/feeds/packages/asterisk-1.6.x/compile] Error 2
make[1]: * /Users/marca56/openwrt/staging_dir/target-mips_uClibc-0.9.30.1/stamp/.package_compile Error 2
make:
* [world] Error 2
marca56:openwrt marca56$

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6174, please stop reporting it.

comment:2 Changed 8 years ago by marca56@…

OK, when we fix it, we won't tell you :)

I'm reporting it because from time to time, people review the tickets for Asterisk and need reminders of broken-ness in platforms they don't necessarily think of.

No need to be rude.

Thanks.

marc.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.