Modify

Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#6400 closed defect (fixed)

/sbin/ifdown shutdown device that serves several connections.

Reported by: Stepanov Andrew <andrusha@…> Owned by: nunojpg
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Hello.

For example in /etc/config/network I have THREE section.
Ethernet 1 - is WAN device.

config interface adsl

option ifname eth1
option proto static
option ipaddr 192.168.1.2
option netmask 255.255.255.0

config interface wan

option auto 1
option ifname eth1
option proto pppoe
option username adsl-user-name
option password qwerty
option defaultroute 1
option peerdns 1

config interface local

option ifname eth1
option auto 1
option proto pppoe
option username adsl-local-user
option password qwerty
option defaultroute 0
option peerdns 0

This configuration is true-life.
Biggest Russian ADSL provider DOMOLINK propose to use two PPPoE connection simultaneously. One for Internet (with speed limit). Second local netwokrk connection.

All seems works fine, but one moment.

# ifup wan
turn off `local' connection

# ifdow wan
turn off `local' connection

And reverse:

# ifup local
turn off `wan' connection

# ifdown local
turn off `wan' connection.

There are problems:

wan' and local' can't start simultaneously.

Correction is simple - see attachments.

ALSO, it would be fine, check for:

# ifdown adsl
address 192.168.1.2
shutdown fully `eth1' device even if there are ppp1 and ppp0.

But this more hard to detect, because 192.168.1.2 is primary IP address for eth1.

Thanks!

Attachments (1)

1.diff (291 bytes) - added by Stepanov Andrew <andrusha@…> 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Stepanov Andrew <andrusha@…>

comment:1 Changed 8 years ago by nunojpg

  • Owner changed from developers to nunojpg
  • Status changed from new to accepted

comment:2 Changed 4 years ago by tripolar

  • Resolution set to fixed
  • Status changed from accepted to closed

problem should be fixed with latest trunk. if not please reopen a new ticket.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.