Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6399 closed defect (duplicate)

mtd upgrade fails with IXP4XX

Reported by: mikejones645@… Owned by: kaloz
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: mtd upgrade fails Cc:

Description

My partition is as following,

RedBoot> fis list
Name FLASH addr Mem addr Length Entry point
RedBoot 0x50000000 0x50000000 0x00080000 0x00000000
linux 0x50080000 0x00800000 0x00400000 0x00800000
FIS directory 0x50FE0000 0x50FE0000 0x0001F000 0x00000000
RedBoot config 0x50FFF000 0x50FFF000 0x00001000 0x00000000

After the system came up.

I used “mtd -r write openwrt-ixp4xx-zImage linux” command to upgrade the linux. The mtd writing was successful without any error messages and it showed,

Writing from openwrt-ixp4xx-zImage to linux ...
Rebooting ...

But after the linux was loaded, I got an exec error as following,

RedBoot(tm) bootstrap and debug environment [ROM]
Red Hat certified release, version 2.04 - built 12:29:55, Dec 4 2009

Platform: IXDP425 Development Platform (IXP4XX) BE
Copyright (C) 2000, 2001, 2002, 2003, 2004, 2007 Free Software Foundation, Inc.

RAM: 0x00000000-0x04000000, [0x00029f98-0x03fc1000] available
FLASH: 0x50000000 - 0x51000000, 128 blocks of 0x00020000 bytes each.

Executing boot script in 1.000 seconds - enter C to abort

RedBoot> fis list
Name FLASH addr Mem addr Length Entry point
RedBoot 0x50000000 0x50000000 0x00080000 0x00000000
linux 0x50080000 0x00800000 0x00400000 0x00800000
FIS directory 0x50FE0000 0x50FE0000 0x0001F000 0x00000000
RedBoot config 0x50FFF000 0x50FFF000 0x00001000 0x00000000
RedBoot> fis load linux
RedBoot> exec
Using base address 0x00800000 and length 0x002ed1e0
command abort - illegal memory access?
RedBoot>

0x002ed1e0 is the length of the linux before upgade.

Could somebody please tell me if anything I did was wrong?

Thanks in advance!

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by thepeople

  • Owner changed from developers to kaloz
  • Status changed from new to assigned

comment:2 Changed 8 years ago by kaloz

  • Resolution set to duplicate
  • Status changed from assigned to closed

dupe of #6060

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.