Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6389 closed defect (fixed)

samba3 package doesn

Reported by: dannybaumann@… Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

The samba3 package currently doesn't include the nmbd daemon, so OpenWrt shares are not announced in the network neighborhood. This is probably ok for most people, but there are devices (like my Technisat HD S2 satellite receiver) which _need_ that kind of announcement.

Attached is a patch which includes nmbd into the build of the package and the package itself. It also fixes some nmbd compilation errors and fixes smbd and nmbd trying to aquire the same lock file (/var/lock/.pid, which is broken anyway).

On my Asus WL-500gP v2, the compiled smbd is now ~1.1MB, the nmbd is ~700kB. It might be a good idea to split out nmbd into a separate subpackage, though, to save those 700k for the people who don't need it.

Attachments (0)

Change History (9)

comment:1 Changed 8 years ago by dannybaumann@…

Ugh, two Trac errors:
1) That summary line should have read 'samba 3 package doesn't include nmbd'
2) Trac doesn't allow me to add my patch, neither as attachment nor inlined, because it thinks it's spam. I've pastebinned it: http://pastebin.ca/1722367

comment:2 Changed 8 years ago by anonymous

This allowed browsing to work correctly for me. Thanks.

comment:3 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Applied in r18991, thanks!

comment:4 Changed 8 years ago by anonymous

After the change, samba3 no longer compiles for me. Compilation stops with the following error:

Linking bin/nmbd
nmbd/nmbd.o: In function `reload_nmbd_services':
nmbd.c:(.text+0xf4): undefined reference to `_fDebug'
nmbd/nmbd.o: In function `terminate':
nmbd.c:(.text+0x134): undefined reference to `_fDebug'

comment:5 Changed 8 years ago by dannybaumann@…

Try disabling SAMBA3_DEBUG in the config.

And yes, this is something I forgot when sending in the patch: For logging still to work, the _fDebug and _fLog functions need to be defined inside of nmbd, just as they are added by 100-avm.patch to smbd (source/smbd/server.c).

comment:6 Changed 8 years ago by nico

  • Resolution fixed deleted
  • Status changed from closed to reopened

Confirmed with r19040 on uml

Florian, can you fix this?

comment:7 Changed 8 years ago by nico

  • Owner changed from developers to florian
  • Status changed from reopened to new

comment:8 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r20041, sorry for the delay.

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.