Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6371 closed defect (fixed)

Kernel 2.6.31.7 pata_via does not work - Kernel panic

Reported by: roland_ffiala@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Kernel panic Cc: roland_ffiala@…

Description

pata on Kernel 2.6.31.5 works OK. Last Trunk Revision with kernel
2.6.31.7 does not work pata_via
on other hardware with ata_piix it boots Ok

00:03: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
scsi0 : pata_via
scsi1 : pata_via
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xfc00 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xfc08 irq 15
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
cpuidle: using governor ladder
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@…>
All bugs added by David S. Miller <davem@…>
Using IPI Shortcut mode
VFS: Cannot open root device "sdb2" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

best regards Roland

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by acinonyx

Is "sdb2" actually the root device?

comment:2 Changed 8 years ago by roland_ffiala@…

yes sdb2 is the root Device.
with 2.6.31.5 the system starts:
scsi1 : pata_via
ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xfc00 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xfc08 irq 15
PNP: No PS/2 controller found. Probing ports directly.
ata1.00: ATA-8: WDC WD3200BEVE-00A0HT0, 11.01A11, max UDMA/100
ata1.00: 625142448 sectors, multi 16: LBA48
ata1.00: limited to UDMA/33 due to 40-wire cable
serio: i8042 KBD port at 0x60,0x64 irq 1
ata1.00: configured for UDMA/33
scsi 0:0:0:0: Direct-Access ATA WDC WD3200BEVE-0 11.0 PQ: 0 ANSI: 5
mice: PS/2 mouse device common for all mice
sd 0:0:0:0: [sda] 625142448 512-byte logical blocks: (320 GB/298 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

sda:

TCP westwood registered
NET: Registered protocol family 17
Bridge firewalling registered
802.1Q VLAN Support v1.8 Ben Greear <greearb@…>
All bugs added by David S. Miller <davem@…>
Using IPI Shortcut mode

sda1 sda2 sda3 sda4 < sda5 >

sd 0:0:0:0: [sda] Attached SCSI disk
ata2.00: ATA-0: AFAYA CF 256M, 1.1, max PIO4
ata2.00: 500736 sectors, multi 0: LBA
ata2.00: configured for PIO4
ata2.00: configured for PIO4
ata2: EH complete
scsi 1:0:0:0: Direct-Access ATA AFAYA CF 256 1.1 PQ: 0 ANSI: 5
sd 1:0:0:0: [sdb] 500736 512-byte logical blocks: (256 MB/244 MiB)
sd 1:0:0:0: [sdb] Write Protect is off
sd 1:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA

sdb: sdb1 sdb2

sd 1:0:0:0: [sdb] Attached SCSI disk

comment:3 Changed 8 years ago by roland_ffiala@…

I have the VIA PLE133T+VT82C686B chipset and with the last revision 18955 the problem is still present. The sdb-Disk is a CopactFlashCard.
Now i found a workaround solution for this problem:
remove from the Patch "300-block2mtd_init.patch"

rm trunk/target/linux/x86/patches-2.6.31/300-block2mtd_init.patch

ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xfc00 irq 14
ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xfc08 irq 15
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
cpuidle: using governor ladder
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@…>
All bugs added by David S. Miller <davem@…>
Using IPI Shortcut mode
ata1.00: ATA-8: WDC WD3200BEVE-00A0HT0, 11.01A11, max UDMA/100
ata1.00: 625142448 sectors, multi 16: LBA48
ata1.00: limited to UDMA/33 due to 40-wire cable
ata1.00: configured for UDMA/33
scsi 0:0:0:0: Direct-Access ATA WDC WD3200BEVE-0 11.0 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] 625142448 512-byte logical blocks: (320 GB/298 GiB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or
FUA

sda: sda1 sda2 sda3 sda4 < sda5 >

sd 0:0:0:0: [sda] Attached SCSI disk
ata2.00: ATA-0: AFAYA CF 256M, 1.1, max PIO4
ata2.00: 500736 sectors, multi 0: LBA
ata2.00: configured for PIO4
ata2.00: configured for PIO4
ata2: EH complete
scsi 1:0:0:0: Direct-Access ATA AFAYA CF 256 1.1 PQ: 0 ANSI: 5
sd 1:0:0:0: [sdb] 500736 512-byte logical blocks: (256 MB/244 MiB)
sd 1:0:0:0: [sdb] Write Protect is off
sd 1:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or
FUA

sdb: sdb1 sdb2

sd 1:0:0:0: [sdb] Attached SCSI disk
VFS: Mounted root (ext2 filesystem) readonly on device 8:18.
Freeing unused kernel memory: 276k freed
Please be patient, while OpenWrt loads ...

comment:4 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r19764.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.