Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6269 closed defect (fixed)

Ethernet doesn't work on DG834GT (Broadcom 96348GW-10)

Reported by: Jiri Jasa <jiri.jasa@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: LAN, DG834GT Cc:

Description

Device seems not to respond on LAN. I supose that this is problem with the switch driver. I'm using trunk version r18603, same happend with r18453. Same problem is described there: https://forum.openwrt.org/viewtopic.php?id=22660 but in my case ethernet is not working even when the „config switch eth1“ section is not configured.

Piece of bootlog:
root@OpenWrt:/# dmesg | grep "eth"
eth1: link forced UP - 100/full - flow control off/off
device eth1 entered promiscuous mode
br-lan: port 1(eth1) entering forwarding state
roboswitch: Probing device eth0: Failed to enable switch
roboswitch: Probing device eth1: found a 5325! It's a 5350.

Attachments (1)

DG834GT.txt (6.6 KB) - added by Jiri Jasa <jiri.jasa@…> 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by Jiri Jasa <jiri.jasa@…>

comment:1 Changed 8 years ago by Jiri Jasa <jiri.jasa@…>

So the probably caused by ignoring „config switch eth1“ section in /etc/config/network.

Here is my config:

cat /etc/config/network
config switch eth1
    option vlan0 "0 1 2 5*"
    option vlan1 "3 5"

config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

config 'interface' 'lan'
    option 'type' 'bridge'
    option 'ifname' 'eth1.0'
    option 'proto' 'static'
    option 'ipaddr' '192.168.2.1'
    option 'netmask' '255.255.255.0'
    option 'nat' '1'


config 'interface' 'dsl'
    option 'ifname' 'eth0'
    option 'proto' 'static'

config 'interface' 'wan'
    option 'ifname' 'eth1.1'
    option 'proto' 'dhcp'

When I do „/etc/init.d/network restart“ robocfg says.

robocfg show
probing eth1
Switch: enabled
Port 0(W):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 1(4):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 2(3): 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 3(2):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 4(1):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 5(C):  10HD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
VLANs: BCM5325/535x enabled mac_check mac_hash

LAN isn't working

When I setup VLANs manually then LAN and WAN works.

robocfg vlan 0 ports "0 1 2 5*"
robocfg vlan 1 ports "3 5*"

robocfg show
probing eth1
Switch: enabled
Port 0(W):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 1(4):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 2(3): 100FD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 3(2):  DOWN enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
Port 4(1):  DOWN enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
Port 5(C):  10HD enabled stp: none vlan: 0 mac: 00:00:00:00:00:00
VLANs: BCM5325/535x enabled mac_check mac_hash
vlan0: 0 1 2 5t
vlan1: 3 5t

comment:2 follow-up: Changed 8 years ago by ma_jk

I got into the same problem after updating to latest trunk on a bcm96358 board.

It looks like vlans config format has changed... it must be like this

https://forum.openwrt.org/viewtopic.php?pid=89948#p89948

comment:3 in reply to: ↑ 2 Changed 8 years ago by Takuto

Replying to ma_jk:

I got into the same problem after updating to latest trunk on a bcm96358 board.

It looks like vlans config format has changed... it must be like this

https://forum.openwrt.org/viewtopic.php?pid=89948#p89948

Thank you, Jiri Jasa and ma_jk! Your posts helped me solve my problem, when I rewrote vlan config like written there https://forum.openwrt.org/viewtopic.php?pid=89948#p89948 , LAN suddenly works!

comment:4 Changed 8 years ago by Jiri Jasa <jiri.jasa@…>

Thank you ma_jk, It works :-)
I think we can close this ticket.

comment:5 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.