Modify

Opened 8 years ago

Closed 6 years ago

Last modified 4 years ago

#6222 closed defect (obsolete)

Weird behavior of "tc qdisc show" on brcm47xx (!!!Remnant of size 2168)

Reported by: Alexey Loukianov <mooroon2@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: tc qdisc show Remnant of size 2168 Cc:

Description

Firmware for dlink dir-320 was build from SVN trunk r18456.
After installing qos-scripts, configuring and starting them up I got following:

root@dir320lx2home:~/Packages# tc qdisc show
!!!Remnant of size 2168

Same command give different (and correct!) output if ran before /etc/init.d/qos start:

root@dir320lx2home:~# tc qdisc show
qdisc pfifo_fast 0: dev eth0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev nas0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev ppp0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1

Any ideas about how to track this bug down?

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by Alexey Loukianov <mooroon2@…>

Have got today some time to check the things.

Absolute minimum required for "Remnant" error to show up is to load up htb qdisc.

root@dir320lx2home:~# tc qdisc show
qdisc pfifo_fast 0: dev eth0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev nas0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev ppp0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
root@dir320lx2home:~#
root@dir320lx2home:~# tc qdisc replace dev imq0 root handle 0: htb
root@dir320lx2home:~# tc qdisc show
!!!Remnant of size 700
root@dir320lx2home:~# tc qdisc replace dev imq0 root handle 0: pfifo
root@dir320lx2home:~# tc qdisc show
qdisc pfifo_fast 0: dev eth0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo 800a: dev imq0 root limit 11000p
qdisc pfifo_fast 0: dev nas0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev ppp0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
root@dir320lx2home:~# tc qdisc del dev imq0 root
root@dir320lx2home:~# tc qdisc show
qdisc pfifo_fast 0: dev eth0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev nas0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
qdisc pfifo_fast 0: dev ppp0 root bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1

So, looks like this problem is not tc-related. Most probably it is caused by some problems with sch_htb.ko kernel module.

comment:2 Changed 6 years ago by nbd

  • Resolution set to obsolete
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.