Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6179 closed defect (worksforme)

working-gcc... failed with ccache on and dirclean

Reported by: moo <moo.tinys@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: toolchain Version: Trunk
Keywords: Cc:

Description

$ make menuconfig
(enable ccache)
$ make dirclean
$ make menuconfig
Checking 'working-make'... ok.
Checking 'case-sensitive-fs'... ok.
Checking 'getopt'... ok.
Checking 'fileutils'... ok.
Checking 'working-gcc'... failed.
Checking 'working-g++'... failed.
Checking 'ncurses'... failed.
Checking 'zlib'... failed.
Checking 'gawk'... ok.
Checking 'flex'... ok.
Checking 'unzip'... ok.
Checking 'bzip2'... ok.
Checking 'patch'... ok.
Checking 'perl'... ok.
Checking 'python'... ok.
Checking 'wget'... ok.
Checking 'gnutar'... ok.
Checking 'svn'... ok.
Checking 'gnu-find'... ok.
Checking 'getopt-extended'... ok.
Checking 'non-root'... ok.

Build dependency: Please install the GNU C Compiler (gcc).
Build dependency: Please install the GNU C++ Compiler (g++).
Build dependency: Please install ncurses. (Missing libncurses.so or ncurses.h)
Build dependency: Please install zlib. (Missing libz.so or zlib.h)

Prerequisite check failed. Use FORCE=1 to override.
strace -f make menuconfig
[pid 14570] stat64("/home/moo/src/openwrt/staging_dir/target-i386_glibc-2.6.1/ccache", 0xbfbec4a4) = -1 ENOENT (No such file or directory)
[pid 14570] mkdir("/home/moo/src/openwrt/staging_dir/target-i386_glibc-2.6.1/ccache", 0777) = -1 ENOENT (No such file or directory)
[pid 14570] write(2, "ccache: failed to create /home/mo"..., 121) = 121
[pid 14570] exit_group(1)               = ?
Process 14570 detached

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce that issue here.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.