Modify

Opened 8 years ago

Last modified 3 years ago

#5927 reopened defect

AR7 on AG241v2/ADM6996LC - Networking/Ethernet still broken in Trunk

Reported by: ronan@… Owned by: florian
Priority: high Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: ar7 ethernet #5288 Cc:

Description

Hi,

I've tried re-opening #5288 but am unable to do so.

I'm trying to build a Linksys AG241b image from trunk and am unable to get the ethernet interface to work.

I'm working off code checked out 2-3 days ago. It uses 2.6.30.7. It flashes okay, boots, the LEDs flicker right, but I'm unable to access the device via the network. I've no serial cable to see what's going on.

The 8.09.1 image works fine, but doesn't have the functionality I need. I'm trying to use trunk to get the swconfig package so I can partition the switch into port based VLANs.

-Ronan

Attachments (1)

AG241-v2_r42170.txt (15.1 KB) - added by M3m3nt0 3 years ago.
bootlog with trunk revision r42170

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by florian

You actually need to pass on the command line cpmac.dumb_switch=1 or cpmac.external_switch=1 to make it work, which needs rebuilding a custom kernel.

comment:2 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 6 years ago by ott@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

This the problem still exists in r29921. Setting the interface into promiscuous mode “solves” it, but is not a solution.

comment:4 Changed 5 years ago by florian

  • Owner changed from developers to florian
  • Status changed from reopened to assigned

comment:5 Changed 5 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with r33750 and r33751

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:7 Changed 4 years ago by Jusic

  • Resolution fixed deleted
  • Status changed from closed to reopened

Nope, this is not fixed, it is still broken in BarrierBreaker 14.07-rc2 and no version newer than Kamikaze worked ever...

comment:8 Changed 3 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with r42169, r42168

Changed 3 years ago by M3m3nt0

bootlog with trunk revision r42170

comment:9 Changed 3 years ago by M3m3nt0

Still not working with r42170 (bootlog attached)

comment:10 Changed 3 years ago by M3m3nt0

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:11 Changed 3 years ago by M3m3nt0

Same problem of the #8187.

The switch is not working with Barrier Breaker 14.07 nor with trunk r43874.

The LED on the router is blinking when pinging from the PC but does not respond.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.