Modify

Opened 8 years ago

Closed 8 years ago

#5862 closed defect (worksforme)

Problems establishing more than one WDS link

Reported by: mflage Owned by: developers
Priority: high Milestone: Kamikaze 8.09.2
Component: base system Version:
Keywords: Cc:

Description

All devices WRT54GL v1.1

Flashed with the latest firmware (8.09.1, r16278)

First thing done is remove the firewall (rm /etc/rc.d/S45firewall) and erase the nvram (mtd erase nvram).

This is my setup:

AP-1 - 192.168.1.1 - 00:23:69:33:57:DD
AP-2 - 192.168.1.2 - 00:22:6B:48:8F:A3
AP-3 - 192.168.1.3 - 00:18:F8:E5:C2:24

First set up WDS between AP-1 and AP2 and confirmed that it worked. Then tried connecting only AP-3 to AP-1 and confirmed success there as well. If I then try to connect both AP-2 and AP-3 to AP-1 none of them work.

/etc/config/wireless for AP-1:

config wifi-device  wl0
      option type     broadcom
      option channel  5

config wifi-iface
      option device   wl0
      option network  lan
      option mode     ap
      option ssid     OpenWrt1

config wifi-iface
      option device   wl0
      option network  lan
      option mode     wds
      option ssid     wds
      option bssid    '00:22:6B:48:8F:A3 00:18:F8:E5:C2:24'
      #used for testing
      #option bssid    00:22:6B:48:8F:A3
      #option bssid    00:18:F8:E5:C2:24

/etc/config/wireless for AP-2 and AP-3 (small difference in ssid for client vif):

config wifi-device  wl0
        option type     broadcom
        option channel  5

config wifi-iface
        option device   wl0
        option network  lan
        option mode     ap
        option ssid     OpenWrt2 (OpenWrt3 for AP-3)

config wifi-iface
        option device   wl0
        option network  lan
        option mode     wds
        option ssid     wds
        option bssid    00:23:69:33:57:DD

By commenting in and out the different bssid at AP-1 and running 'wifi' I'm able to get the different APs up and running in a couple of seconds, but never together.

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by florian

  • Milestone changed from Kamikaze to Kamikaze 8.09.2
  • Priority changed from normal to high

comment:2 follow-up: Changed 8 years ago by mflage

I've tested some more and just doing:

ifconfig wds0.2 up
brctl addif br-lan wds0.2

... brings up the second wds link. So the problem is mostly trivial and should be pretty straight-forward to fix. If one only knew how... ;)

comment:3 in reply to: ↑ 2 Changed 8 years ago by Hanno Schupp <hanno.schupp@…>

The issue may be in the for you save the WDS links.
Something like this works for me (using your MACs as example:

config wifi-device wl0

option type broadcom
option channel 5

config wifi-iface

option device wl0
option network lan
option mode ap
option encryption none
option ssid OpenWrt2 (OpenWrt3 for AP-3)

config wifi-iface

option device wl0
option network lan
option mode wds
option ssid wds
option encryption none
option bssid 00:18:F8:E5:C2:24

config wifi-iface

option device wl0
option network lan
option mode wds
option bssid 00:22:6B:48:8F:A3

Replying to mflage:

I've tested some more and just doing:

ifconfig wds0.2 up
brctl addif br-lan wds0.2

... brings up the second wds link. So the problem is mostly trivial and should be pretty straight-forward to fix. If one only knew how... ;)

comment:4 Changed 8 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

@mflage:
As Hanno pointed out, your config is wrong. His proposed solution matches the way it should be configured.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.