Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#5842 closed defect (fixed)

Luci returns 'Not Found'

Reported by: Noam Meltzer <tsnoam@…> Owned by: jow
Priority: normal Milestone: Barrier Breaker 14.07
Component: luci Version: Trunk
Keywords: luci Cc:

Description

According to the following forum thread:
https://forum.openwrt.org/viewtopic.php?pid=94217#p94217

It appears that there is a problem in trunk with Luci. When trying to access Luci from the web the only thing seen is 'Not Found'.

The solution was to execute:
opkg install luci-fastindex

This package should be added to the default packages supplied with the image.
Reproduced on Linksys WRT54GS & WRT160NL

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by agb

  • Milestone changed from Kamikaze 8.09.2 to Kamikaze

Reassigning milestone to Kamikaze, this doesn't have to do with 8.09.2

comment:2 Changed 8 years ago by Rodrigo Nogueira

I'm getting the same message running r17651 on Ubiquiti Bullet 5.

comment:3 Changed 8 years ago by ^k

I can confirm this on Ubiquity Router Station running trunk r17679.

My solution was:

opkg install luci-fastindex
opkg install luci-admin-full (failed with error but it works)

comment:4 Changed 8 years ago by beastmaster_at@…

Got the same problem here on Kernel 2.4 and 2.6.

Sys: WRT54GL v1.1
Firmware: r18405

solution:

opkg install luci-fastindex
opkg install luci-admin-full

Something interessting on 2.4:
Logging in over telnet after installing openwrt-wrt54g-squashfs.bin (brcm-2.4) and setting the passwd. After that I wasn't able to connect over http.
But reinstalling 2.4 over the cmdline with openwrt-brcm-2.4-squashfs.trx and going directly over http worked fine.

comment:5 Changed 8 years ago by Pavel Roskin <proski@…>

I have the same problem with the current precompiled trunk. I'm using http://downloads.openwrt.org/snapshots/trunk/brcm47xx/openwrt-wrt54g-squashfs.bin on WRT54GL 1.1.

{{{root@OpenWrt:~# opkg list_installed |grep -i luci
luci-core - 0.9+svn5617-1
luci-http - 0.9+svn5617-1
luci-lmo - 0.9+svn5617-1
luci-lucid - 0.9+svn5617-1
luci-nixio - 0.9+svn5617-1
luci-px5g - 0.9+svn5617-1
luci-sgi-cgi - 0.9+svn5617-1
luci-sys - 0.9+svn5617-1
luci-theme-base - 0.9+svn5617-1
luci-theme-openwrt - 0.9+svn5617-1
luci-uci - 0.9+svn5617-1
luci-web - 0.9+svn5617-1
root@OpenWrt:~#}}}

I had to install several packages from http://downloads.openwrt.org/snapshots/trunk/brcm47xx/packages/ manually to satisfy all dependencies:

{{{root@OpenWrt:~# opkg list_installed |grep -i luci |grep 5602
luci-admin-core - 0.9+svn5602-1
luci-admin-full - 0.9+svn5602-1
luci-cbi - 0.9+svn5602-1
luci-fastindex - 0.9+svn5602-1
luci-i18n-english - 0.9+svn5602-1
luci-ipkg - 0.9+svn5602-1
luci-uvl - 0.9+svn5602-1
root@OpenWrt:~#}}}

Now luci is working.

comment:6 Changed 8 years ago by sean@…

Same problem, UBNT RSPro precompiled trunk build, r18526. Out of the box, HTTP server redirects to http://192.168.1.1/luci and returns not found, which sort of makes sense since luci is not installed at that time, but the redirect probably shouldn't be there in that case.
Installing luci-admin-full installs multiple packages but does not change the HTTP response.

Installing luci-fastindex results in an apparently working system.

comment:7 Changed 8 years ago by thepeople

  • Component changed from packages to luci
  • Owner changed from developers to jow
  • Status changed from new to assigned

comment:8 Changed 8 years ago by desowin@…

Same problem on Backfire 10.03, my solution:
opkg install luci-fastindex
opkg install uhttpd-mod-lua

comment:9 Changed 7 years ago by jow

  • Resolution set to fixed
  • Status changed from assigned to closed

This seems to be the symptom of an incomplete installation, all the workarounds above just call "rm /tmp/luci-indexcache" in the end which will force luci to rebuild its menus. I'll close this as worksforme now as "opkg install luci" generally does the right thing and works ootb.

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.