Modify

Opened 8 years ago

Last modified 4 years ago

#5836 new defect

mmc-over-gpio on fon does not work

Reported by: haxwithaxe Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Kamikaze 8.09
Keywords: mmc, gpio, kmod, fon Cc: mannkoepke@…

Description

I get the following error when running the init script that comes with kmod-mmc_over_gpio in kamikaze 8.09.
"mkdir: cannot create directory '/config/gpiommc/default': No such file or directory"
I have tried to change the location of the CONFIGFS_DIR and none of the values have worked. My /dev shows no sign of a mmc device either.
I have posted this in the forum and no one has responded for almost 2 weeks. If I'm just doing something wrong let me know please.
I am running Kamikaze 8.09 on the fon v2100.
$uname -r 2.6.26.5

Attachments (0)

Change History (5)

comment:1 follow-up: Changed 8 years ago by anonymous

If you need storage, get a router with USB.

comment:2 in reply to: ↑ 1 Changed 8 years ago by haxwithaxe

Replying to anonymous:

If you need storage, get a router with USB.

That's not the point. If it's in the stable repo it should work. Also this could be symptomatic of a problem and something that wasn't seen in the initial testing that the developers might want to fix.
I don't know for sure what's different but I am now using the piranha 2.0(based heavily on openwrt kamikaze 8.09) firmware and the drivers(not the init script) seem to work fine.

comment:3 Changed 8 years ago by haxwithaxe

the shell script in piranha work as well. still not sure what's different that it works though.

comment:4 Changed 8 years ago by masterq

I have the same hardware and the same problem, but an newer version of openwrt.

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.