Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#5792 closed defect (fixed)

syslog-ng3 and libnet

Reported by: Branko Majic Owned by: developers
Priority: low Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc: branko@…

Description

For some reason syslog-ng3 picks-up the system library libnet and tries to compile with the source spoofing capability (which is implemented using the libnet library). At the same time syslog-ng doesn't pick it up, leaving me a bit curious about it. This might be caused by the same problem as ticket #5791. One solution would be to explicitly disable libnet dependence in syslog-ng3 by passing --disable-spoof-source to 'configure'.

I've confirmed that syslog-ng 1.6.12 by default doesn't enable source spoofing, while syslog-ng 3.0.4 does (it auto-detects presence of libnet and uses it if available).

Let me know if you need some more details.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by nico

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [19819]

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.