Modify

Opened 8 years ago

Closed 8 years ago

#5765 closed defect (worksforme)

Kamikaze 8.09.x cannot be recompiled for WGT634U

Reported by: resul-cetin@… Owned by: agb
Priority: high Milestone: Kamikaze 8.09.2
Component: base system Version:
Keywords: Cc:

Description

Hi,
I have a WGT634U and wanted to update to the new version of WGT634U, but read that it does not work due to some bad bug in 8.09.1. Because of that I fetched the current source from the 8.09 branch, changed "Target System (Broadcom BCM947xx/953xx [2.6])" in make menuconfig and then without any further changes done a compilation just by calling make. The output was flashed with CFE. The result was catastrophic. Output is just (in a loop):

CFE version 1.0.34 for BCM95365R (32bit,SP,LE)
Build Date: Tue Feb 24 03:21:41 CST 2004 (root@jackylinux)
Copyright (C) 2000,2001,2002 Broadcom Corporation.        

Add MAC client version(DNI).
Initializing Arena.         
Initializing Devices.       
et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
CPU type 0x29007: 200MHz                             
Total memory: 0x2000000 bytes (32MB)                 

Total memory used by CFE:  0x81BB1280 - 0x82000000 (4517248)
Initialized Data:          0x81BB1280 - 0x81BB3E90 (11280)  
BSS Area:                  0x81BB3E90 - 0x81BB45D0 (1856)   
Local Heap:                0x81BB45D0 - 0x81FB45D0 (4194304)
Stack Area:                0x81FB45D0 - 0x81FB65D0 (8192)   
Text (code) segment:       0x81FB65E0 - 0x81FFFFB0 (301520) 
Boot area (physical):      0x01B70000 - 0x01BB0000          
Relocation Factor:         I:E23B65E0 - D:01BB0280          

configure vlans
*****************************************************************
*********************** VLAN Driver initial  ********************
*****************************************************************
Process LAN port(2-5) vlan Architecture...                       
SUCCESS: trying to create VLAN 0 for switch                      
SUCCESS: trying to add LAN port                                  

Process WAN port(2-5) vlan Architecture...
SUCCESS: trying to create VLAN 0 for switch
SUCCESS: trying to add WAN port            
SUCCESS: enable ports  success             
configure vlans...done                     
Device eth0:  hwaddr XX-XX-XX-XX-XX-XX, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway 192.168.1.1, nameserver 192.168.1.1                            
Loader:elf Filesys:raw Dev:flash0.os File: Options:(null)                      
***************************                                                    
****  MAC Client V1.0  ****                                                    
***************************                                                    
et0macaddr value :flag =0 value=XX-XX-XX-XX-XX-XX                              
et1macaddr value :flag =0 value=xx-xx-xx-xx-xx-xx                              
MAC exist at least one                                                         
system ethernet mac exist and not default....                                  
Skip mac client process.....                                                   
Loading: 0x80001000/3768 Entry at 0x80001000                                   
Closing network.                                                               
et0: link down                                                                 
Starting program at 0x80001000                                                 
**Exception 32: EPC=80006B7C, Cause=00000020, VAddr=00000000                   
                RA=80400240, PRID=00029007                                     

        0  ($00) = 00000000     AT ($01) = 00000000
        v0 ($02) = 00000FAB     v1 ($03) = 80002000
        a0 ($04) = 81BB9280     a1 ($05) = 802934AC
        a2 ($06) = 80293420     a3 ($07) = 43464531
        t0 ($08) = 804FC22E     t1 ($09) = 81FB60C8
        t2 ($10) = 80400000     t3 ($11) = 00000000
        t4 ($12) = 00000000     t5 ($13) = 00000000
        t6 ($14) = 00000000     t7 ($15) = 00000000
        s0 ($16) = 80000000     s1 ($17) = 0000006D
        s2 ($18) = 000000FF     s3 ($19) = 000000FF
        s4 ($20) = 000000FF     s5 ($21) = 0000000C
        s6 ($22) = 00000010     s7 ($23) = 00001000
        t8 ($24) = FFFFFFC8     t9 ($25) = 804005C4
        k0 ($26) = 30313030     k1 ($27) = 81FF877C
        gp ($28) = 81BB9280     sp ($29) = 81FB6128
        fp ($30) = 00000010     ra ($31) = 80400240

The first idea was that I did something wrong while flashing. I fetched the kamikaze binary for 8.09 and flashed it. Worked perfectly.... so it had to be my build. First idea that there is a amd64 specific problem. So switched from my Debian sid amd 64 to my Debian lenny i386 and did a rebuild from a fresh svn export.... same "bad" result. So maybe the svn version is broken. Did a fresh build from the 8.09 sources and got the same "bad" output.

So my idea is that the source from svn/download is not buildable for WGT634U. Is there anything special to get it working? Is this a known problem? Anything I could do for more debug information (the current output looks like CFE output when doing the decompress or starting the uncompressed kernel.... dunno).

So every build from sources with just these two small steps (make menuconfig with changing to "Broadcom BCM947xx/953xx [2.6]" and then make) created a non-working openwrt-wgt634u-squashfs.bin

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by jow

  • Component changed from packages to base system
  • Milestone changed from Kamikaze to Kamikaze 8.09.2
  • Priority changed from normal to high

Please rebuild with

comment:2 Changed 8 years ago by jow

Ignore the broken comment above :) Looks like the kernel does not start at all

comment:3 follow-up: Changed 8 years ago by anonymous

Images generated from the 8.09 branch work on my wgt634u. Built on a Lenny amd64 box (same one used for the 8.09.1 release.) I used the release-build (http://downloads.openwrt.org/kamikaze/8.09.1/release-build.sh) script to initiate builds for all targets, but you can kick off builds for specific targets by passing them as arguments:

./release-build.sh brcm47xx

While this could be considered "something special" it does not contain any magic settings that would produce working images whereas a clean checkout would not. The build host is not used for anything apart from 8.09 builds. I started with a minimal debootstrap, installed svn, build-essential and make, then added additional packages as our buildsystem yelled at me.

Output from successful flashing/boot is below.

CFE> ifconfig eth0 -auto
Device eth0:  hwaddr 00-09-5B-F8-B5-5D, ipaddr 192.168.1.75, mask 255.255.255.0
        gateway 192.168.1.254, nameserver 192.168.1.254, domain foobar.lan
*** command status = 0
CFE> flash -noheader 192.168.1.74:openwrt-wgt634u-squashfs.bin flash0.os
Reading 192.168.1.74:openwrt-wgt634u-squashfs.bin: Done. 2363392 bytes read
Programming...done. 2363392 bytes written
*** command status = 0
CFE> reboot


CFE version 1.0.34 for BCM95365R (32bit,SP,LE)
Build Date: Tue Feb 24 03:21:41 CST 2004 (root@jackylinux)
Copyright (C) 2000,2001,2002 Broadcom Corporation.

Add MAC client version(DNI).
Initializing Arena.
Initializing Devices.
et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
CPU type 0x29007: 200MHz
Total memory: 0x2000000 bytes (32MB)

Total memory used by CFE:  0x81BB1280 - 0x82000000 (4517248)
Initialized Data:          0x81BB1280 - 0x81BB3E90 (11280)
BSS Area:                  0x81BB3E90 - 0x81BB45D0 (1856)
Local Heap:                0x81BB45D0 - 0x81FB45D0 (4194304)
Stack Area:                0x81FB45D0 - 0x81FB65D0 (8192)
Text (code) segment:       0x81FB65E0 - 0x81FFFFB0 (301520)
Boot area (physical):      0x01B70000 - 0x01BB0000
Relocation Factor:         I:E23B65E0 - D:01BB0280

configure vlans
*****************************************************************
*********************** VLAN Driver initial  ********************
*****************************************************************
Process LAN port(2-5) vlan Architecture...
SUCCESS: trying to create VLAN 0 for switch
SUCCESS: trying to add LAN port

Process WAN port(2-5) vlan Architecture...
SUCCESS: trying to create VLAN 0 for switch
SUCCESS: trying to add WAN port
SUCCESS: enable ports  success
configure vlans...done
Device eth0:  hwaddr 00-09-5B-F8-B5-5D, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Loader:elf Filesys:raw Dev:flash0.os File: Options:(null)
***************************
****  MAC Client V1.0  ****
***************************
et0macaddr value :flag =0 value=00-09-5b-f8-b5-5d
et1macaddr value :flag =0 value=00-09-5b-f8-b5-5e
MAC exist at least one
system ethernet mac exist and not default....
Skip mac client process.....
Loading: 0x80001000/3768 Entry at 0x80001000
Closing network.
et0: link down
Starting program at 0x80001000
Linux version 2.6.25.20 (andy@stable-sandbox) (gcc version 4.1.2) #1 Thu Sep 10 22:31:36 UTC 2009
CPU revision is: 00029007 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x05, vendor 0x4243)
ssb: Core 1 found: Fast Ethernet (cc 0x806, rev 0x06, vendor 0x4243)
ssb: Core 2 found: IPSEC (cc 0x80B, rev 0x01, vendor 0x4243)
ssb: Core 3 found: USB 1.1 Hostdev (cc 0x808, rev 0x02, vendor 0x4243)
ssb: Core 4 found: PCI (cc 0x804, rev 0x08, vendor 0x4243)
ssb: Core 5 found: MIPS 3302 (cc 0x816, rev 0x01, vendor 0x4243)
ssb: Core 6 found: MEMC SDRAM (cc 0x80F, rev 0x00, vendor 0x4243)
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0806, irq 2 => 2
ssb: set_irq: core 0x0804, irq 0 => 3
early_nvram_init: WGT634U NVRAM found.
ssb: Sonics Silicon Backplane found at address 0x18000000
Swapping serial ports!
Serial init done.
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal          0 ->     8192
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0:        0 ->     8192
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
Primary instruction cache 8kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 4kB, 2-way, VIPT, no aliases, linesize 16 bytes
Synthesized clear page handler (26 instructions).
Synthesized copy page handler (46 instructions).
PID hash table entries: 128 (order: 7, 512 bytes)
console [ttyS0] enabled
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Memory: 29824k/32768k available (2073k kernel code, 2944k reserved, 308k data, 128k init, 0k highmem)
Mount-cache hash table entries: 512
net_namespace: 540 bytes
NET: Registered protocol family 16
ssb: PCIcore in host mode found
Registering a PCI bus after boot
PCI: Fixing up bridge 0000:00:00.0
PCI: Fixing up device 0000:00:00.0
PCI: Fixing latency timer of device 0000:00:00.0 to 168
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
detected lzma initramfs
initramfs: LZMA lc=1,lp=2,pb=2,origSize=512
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250: ttyS1 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250.0: ttyS0 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250.0: ttyS1 at MMIO 0xb8000300 (irq = 3) is a 16550A
b44.c:v2.0
eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:09:5b:f8:b5:5d
flash init: 0x1c000000 0x02000000
Physically mapped flash: Found 1 x16 devices at 0x0 in 16-bit bank
 Intel/Sharp Extended Query Table at 0x0031
Using buffer write method
cfi_cmdset_0001: Erase suspend on write enabled
Flash device: 0x800000 at 0x1fc00000
bootloader size: 655360
Updating TRX offsets and length:
old trx = [0x0000001c, 0x0000090c, 0x000bd400], len=0x00221000 crc32=0x7b7980f8
new trx = [0x0000001c, 0x0000090c, 0x000bd400], len=0x000bd400 crc32=0xf51ec806
Done
Creating 4 MTD partitions on "Physically mapped flash":
0x00000000-0x000a0000 : "cfe"
0x000a0000-0x007e0000 : "linux"
0x0015d400-0x007e0000 : "rootfs"
mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2C0000, len=520000
0x002c0000-0x007e0000 : "rootfs_data"
0x007e0000-0x00800000 : "nvram"
Registered led device: power
TCP vegas registered
NET: Registered protocol family 1
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 128k freed
Please be patient, while OpenWrt loads ...
Algorithmics/MIPS FPU Emulator v1.5
- preinit -
Press CTRL-C for failsafe
diag: Detected 'Netgear WGT634U'
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
roboswitch: Probing device eth0: found!
b44: eth0: powering down PHY
jffs2 not ready yet; using ramdisk
mini_fo: using base directory: /
mini_fo: using storage directory: /tmp/root
- init -

Please press Enter to activate this console.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
PPP generic driver version 2.4.2
br-lan: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
device eth0.0 entered promiscuous mode
device eth0 entered promiscuous mode
br-lan: port 1(eth0.0) entering learning state
br-lan: topology change detected, propagating
br-lan: port 1(eth0.0) entering forwarding state
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
jffs2_build_filesystem(): unlocking the mtd device... done.
jffs2_build_filesystem(): erasing all blocks after the end marker... done.
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs

BusyBox v1.11.2 (2009-09-06 01:22:56 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 KAMIKAZE (8.09.1, r17567) ----------------------------
  * 10 oz Vodka       Shake well with ice and strain
  * 10 oz Triple sec  mixture into 10 shot glasses.
  * 10 oz lime juice  Salute!
 ---------------------------------------------------
root@OpenWrt:/# cat /proc/diag/model
Netgear WGT634U
root@OpenWrt:/#

comment:4 in reply to: ↑ 3 Changed 8 years ago by agb

  • Owner changed from developers to agb
  • Status changed from new to assigned

Replying to anonymous:
Oops, wasn't logged in, above comment is from me.

comment:5 Changed 8 years ago by agb

  • Resolution set to worksforme
  • Status changed from assigned to closed

No response from original reporter, error cannot be reproduced, closing.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.