Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#5742 closed defect (no_response)

Unable to get wan ip address from dhcp server for ubiquity routerstation in r17321`

Reported by: drkhosla@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: preinit ar71xx Cc: drkhosla@…

Description

I am unable to get any IP address from dhcp server when I set proto to dhcp. It works for r17320 but not for r17321.

The only file added in r17321 is

target/linux/ar71xx/base-files/etc/preinit.arch. "

My target is ar71xx and target profile is ubiquity routerstion.

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by freifunk somakoma de

I can confirm this. 17321 breaks ethernet completely on the routerstation. The interfaces are there but seem to be completely nonfunctional.

Before 17321 at least eth0 (lan) worked, but beginning with 17247 eth1 doesn't receive any packets (no arp replies, no dhcp replies, no pongs). I'm not sure if this is related and i'll file another bug report for that eth1 problem if a fix to this current problem won't help there.

Following are some infos that might hopefully help to find the bug. If you need more information just send me a mail.

ifconfig

br-lan    Link encap:Ethernet  HWaddr 00:15:6D:C1:23:58  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:403 (403.0 B)

eth0      Link encap:Ethernet  HWaddr 00:15:6D:C1:23:58  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:368 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:22080 (21.5 KiB)  TX bytes:0 (0.0 B)
          Interrupt:4 

eth1      Link encap:Ethernet  HWaddr 00:15:6D:C1:23:59  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:186 errors:0 dropped:0 overruns:0 frame:0
          TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:52076 (50.8 KiB)  TX bytes:57629 (56.2 KiB)
          Interrupt:5 
bridge name     bridge id               STP enabled     interfaces
br-lan          8000.00156dc12358       no              eth0

/etc/config/network is default:

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'ifname' 'eth0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.1'
        option 'netmask' '255.255.255.0'

config 'interface' 'wan'
        option 'ifname' 'eth1'
        option 'proto' 'dhcp'

uname -a

Linux bg23-rs 2.6.30.5 #5 Thu Sep 3 20:08:46 CEST 2009 mips unknown

dmesg

Linux version 2.6.30.5 (soma@kali) (gcc version 4.1.2) #5 Thu Sep 3 20:08:46 CEST 2009
prom: fw_arg0=00000002, fw_arg1=80050028, fw_arg2=80050000, fw_arg3=0000001b
MyLoader: sysp=00000000, boardp=00000000, parts=ace50014
console [early0] enabled
CPU revision is: 00019374 (MIPS 24Kc)
Atheros AR7161 rev 2, CPU:680.000 MHz, AHB:170.000 MHz, DDR:340.000 MHz
Determined physical RAM map:
 memory: 04000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00004000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00004000
On node 0 totalpages: 16384
free_area_init_node: node 0, pgdat 802bc340, node_mem_map 81000000
  Normal zone: 128 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 16256 pages, LIFO batch:3
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
Kernel command line: rootfstype=squashfs,yaffs,jffs2 noinitrd console=ttyS0,115200
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=000508d2
Readback ErrCtl register=000508d2
NR_IRQS:56
PID hash table entries: 256 (order: 8, 1024 bytes)
Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
Memory: 61864k/65536k available (1993k kernel code, 3600k reserved, 429k data, 136k init, 0k highmem)
SLUB: Genslabs=7, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Calibrating delay loop... 452.19 BogoMIPS (lpj=2260992)
Mount-cache hash table entries: 512
net_namespace: 1008 bytes
NET: Registered protocol family 16
MIPS: machine is Ubiquiti RouterStation
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
pci 0000:00:00.0: reg 10 32bit mmio: [0x000000-0xfffffff]
pci 0000:00:00.0: reg 14 io port: [0x00-0xff]
pci 0000:00:00.0: supports D1 D2
pci 0000:00:00.0: PME# supported from D0 D1 D2 D3hot
pci 0000:00:00.0: PME# disabled
pci 0000:00:11.0: reg 10 32bit mmio: [0x000000-0x00ffff]
pci 0000:00:13.0: reg 10 32bit mmio: [0x000000-0x00ffff]
PCI: mapping irq 48 to pin1@0000:00:11.0
PCI: mapping irq 50 to pin1@0000:00:13.0
NET: Registered protocol family 2
Switched to high resolution mode on CPU 0
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 2048 (order: 2, 16384 bytes)
TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
TCP: Hash tables configured (established 2048 bind 2048)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
yaffs Sep  3 2009 12:35:59 Installing.
msgmni has been set to 120
alg: No test for lzma (lzma-generic)
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
console handover: boot [early0] -> real [ttyS0]
ag71xx_mdio: probed
eth0: Atheros AG71xx at 0xb9000000, irq 4
eth0: ADM6996 PHY driver attached.
eth0: connected to PHY at 0:14 [uid=10200007, driver=Infineon ADM6996]
eth1: Atheros AG71xx at 0xba000000, irq 5
eth1: connected to 4 PHYs
Atheros AR71xx SPI Controller driver version 0.2.4
m25p80 spi0.0: mx25l128 (16384 Kbytes)
Searching for RedBoot partition table in spi0.0 at offset 0xfe0000
Searching for RedBoot partition table in spi0.0 at offset 0xff0000
5 RedBoot partitions found on MTD device spi0.0
Creating 5 MTD partitions on "spi0.0":
0x000000000000-0x000000030000 : "RedBoot"
0x000000030000-0x000000110000 : "kernel"
0x000000110000-0x000000ff0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2C0000, len=D30000
0x0000002c0000-0x000000ff0000 : "rootfs_data"
0x000000ff0000-0x000000fff000 : "FIS directory"
0x000000fff000-0x000001000000 : "RedBoot config"
Atheros AR71xx hardware watchdog driver version 0.1.0
ar71xx-wdt: timeout=15 secs (max=25)
TCP westwood registered
NET: Registered protocol family 17
Bridge firewalling registered
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 136k freed
Please be patient, while OpenWrt loads ...
gpio-buttons driver version 0.1.1
input: gpio-buttons as /devices/platform/gpio-buttons/input/input0
Button Hotplug driver version 0.3.1
Registered led device: ubnt:green:rf
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
device eth0 entered promiscuous mode
ar71xx: pll_reg 0xb8050014: 0x1099
eth1: link up (100Mbps/Full duplex)
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ip_tables: (C) 2000-2006 Netfilter Core Team
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ar71xx-ehci ar71xx-ehci: Atheros AR71xx built-in EHCI controller
ar71xx-ehci ar71xx-ehci: new USB bus registered, assigned bus number 1
ar71xx-ehci ar71xx-ehci: irq 3, io mem 0x1b000000
ar71xx-ehci ar71xx-ehci: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel paramater, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
ath_hal: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
ath_hal: 2009-05-08 (AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, REGOPS_FUNC, XR)
ath_pci: trunk
wlan: trunk
wlan: mac acl policy registered
ath_rate_minstrel: Minstrel automatic rate control algorithm 1.2 (trunk)
ath_rate_minstrel: look around rate set to 10%
ath_rate_minstrel: EWMA rolloff level set to 75%
ath_rate_minstrel: max segment size in the mrr set to 6000 us
PCI: Enabling device 0000:00:11.0 (0000 -> 0002)
Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
ath_pci: wifi0: Atheros 5413: mem=0x10000000, irq=48
PCI: Enabling device 0000:00:13.0 (0000 -> 0002)
Atheros HAL provided by OpenWrt, DD-WRT and MakSat Technologies
wifi1: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi1: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi1: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi1: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi1: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi1: H/W encryption support: WEP AES AES_CCM TKIP
ath_pci: wifi1: Atheros 5212: mem=0x10010000, irq=50
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ar71xx-ohci ar71xx-ohci: Atheros AR71xx built-in OHCI controller
ar71xx-ohci ar71xx-ohci: new USB bus registered, assigned bus number 2
ar71xx-ohci ar71xx-ohci: irq 14, io mem 0x1c000000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ar71xx-wdt: enabling watchdog timer
device br-lan entered promiscuous mode
device br-lan left promiscuous mode
device eth1 entered promiscuous mode

Some tcpdumps:

br-lan: no rx at all

eth0, which belongs to br-lan: i see traffic, but rs isn't responding to arp. (tcpdumped on the routerstation while trying to ping from 192.168.1.2)

00:06:31.086171 ARP, Request who-has 192.168.1.1 tell 192.168.1.2, length 46
00:06:32.086214 ARP, Request who-has 192.168.1.1 tell 192.168.1.2, length 46
00:06:33.651275 ARP, Request who-has 192.168.1.1 tell 192.168.1.2, length 46
00:06:34.651318 ARP, Request who-has 192.168.1.1 tell 192.168.1.2, length 46

eth1: no arp replies (dump from my main router 192.168.0.1. Routerstation asks for IP, Router answers, but they seem to be not heard by the routerstation. RS also doesn't respond to arp requests from the main router)

00:02:50.019854 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
00:02:50.020722 IP 192.168.0.1.67 > 192.168.0.207.68: BOOTP/DHCP, Reply, length 300
00:02:53.020140 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
00:02:53.022187 IP 192.168.0.1.67 > 192.168.0.207.68: BOOTP/DHCP, Reply, length 300
00:02:56.022685 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
00:02:56.023335 IP 192.168.0.1 > 192.168.0.207: ICMP echo request, id 9853, seq 0, length 28
00:02:58.014245 ARP, Request who-has 192.168.0.207 tell 192.168.0.1, length 46
00:02:59.014449 ARP, Request who-has 192.168.0.207 tell 192.168.0.1, length 46
00:02:59.025919 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
00:02:59.105006 IP 192.168.0.1.67 > 192.168.0.207.68: BOOTP/DHCP, Reply, length 300
00:02:59.105396 IP 192.168.0.1.67 > 192.168.0.207.68: BOOTP/DHCP, Reply, length 300
00:03:02.029139 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request [|bootp]
00:03:02.030087 IP 192.168.0.1.67 > 192.168.0.207.68: BOOTP/DHCP, Reply, length 300

if pinging a host from the RS and tcpdumping at the same time on the RS i see on br-lan

00:13:44.750058 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 28
00:13:45.750066 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 28
00:13:47.750057 ARP, Request who-has 192.168.1.2 tell 192.168.1.1, length 28

but no arp requests going out eth0 and no replies received.

comment:2 follow-up: Changed 8 years ago by soma

Update: after a hint from Juhosg i recompiled current trunk (17536) without ADM6996 and both interfaces work as expected. So the problem is supposedly with the switch driver.

comment:3 in reply to: ↑ 2 Changed 8 years ago by serg@…

Replying to soma:

So the problem is supposedly with the switch driver.

The eth0 interface does not receive a link state from the phy driver (adm6996.c) and the RUNNING flag is always cleared. The eth1 inteface connected the port5 marked as a tag port. This prevent packets from receiving by the eth1.

I made a patch that replaces the adm6996_config_aneg() and adm6996_read_status() functions with the genphy_config_aneg() and genphy_config_aneg() and removes the tag port flag. With this patch both interfaces are operational.

comment:4 Changed 8 years ago by JimWright

This may be related to: /ticket/6021.html

comment:5 Changed 8 years ago by thepeople

Is this still a issue on trunk?

comment:6 Changed 7 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.