Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#5714 closed enhancement (duplicate)

ddns-scripts - sed Substitution Problem with "ip_url" and "update_url" config field

Reported by: senor.michael_f_herbst.aaj@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Kamikaze 8.09
Keywords: ddns-scripts Cc:

Description

If one uses a personalized ip_url and/or update_url an ip upload to a ddns - server is not possible due to a substitution error caused by sed. The substitution in the file "/usr/lib/ddns/dynamic_dns_updater.sh", about line 250 produces this error: sed seems to interprete the "/" and ":" chars of the urls as parameters for the substitution. I fix the problem by replacing "/" with "\/" and ":" with "\:". So after adding the following two lines between replace_value=... and final_url=... , I get no error any more.

replace_value=$(echo $replace_value | sed s/"\/"/'\\\/'/g )
replace_value=$(echo $replace_value | sed s/"\:"/"\\\:"/g )

Please note that I append my modified "dynamic_dns_updater.sh".

I'm new to openwrt and this was the first time I've used sed, so maybe there's a better solution.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5715.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.