Modify

Opened 12 years ago

Closed 12 years ago

Last modified 5 years ago

#557 closed defect (worksforme)

dnsmasq does work with SRV DNS

Reported by: dnehring@… Owned by: developers
Priority: normal Milestone: 0.9/rc6
Component: base system Version:
Keywords: Cc:

Description

For SIP you normally need DNS SRV support. Unfortunately, dnsmasq currently does not support it:

$ host -t srv _sip._udp.nikotel.com
_sip._udp.nikotel.com has SRV record 0 0 5060 calamar0.nikotel.com.

tcpdump (direct):
23:17:51.297867 IP 192.168.200.33.26999 > 217.14.160.130.53: 1+ SRV? _sip._udp.nikotel.com. (39)
23:17:51.378977 IP 217.14.160.130.53 > 192.168.200.33.26999: 1 1/2/1 SRV[|domain]
23:17:51.380899 IP 192.168.200.33.18477 > 217.14.160.130.53: 1+ A? calamar0.nikotel.com. (38)
23:17:51.462386 IP 217.14.160.130.53 > 192.168.200.33.18477: 1 1/2/0 A 63.214.186.6 (98)

tcpdump (via dnsmasq on openwrt):
23:32:32.046108 IP 192.168.200.72.2047 > 192.168.200.1.53: 5+ SRV? _sip._udp.nikotel.com. (39)
23:32:32.047355 IP 192.168.200.1.53 > 192.168.200.72.2047: 5* 0/0/0 (39)

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by nico

  • Resolution set to worksforme
  • Status changed from new to closed

Theese records are supported, but ignored because of the filterwin2k line in /etc/dnsmasq.conf.

From the dnsmasq manual:

       -f, --filterwin2k
              Later versions of windows make periodic DNS requests which don't get sensible answers from the public DNS and can cause problems by trigger-
              ing  dial-on-demand  links. This flag turns on an option to filter such requests. The requests blocked are for records of types SOA and SRV,
              and type ANY where the requested name has underscores, to catch LDAP requests.

If you need dnsmasq to forward SRV queries, just comment out this line.

comment:2 Changed 12 years ago by dnehring@…

Confirmed.

comment:3 Changed 5 years ago by sorosj@…

the option in the luci web interface is called "filter useless" and the description "Do not forward requests requests that cannot be answered by public name servers" is pretty misleading since now google uses SRV records for it's gtalk service, and some other things have started also using SRV records more frequently.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.