Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#5483 closed defect (fixed)

Error compiling Atheros BOARD on trunk version with linux: 2.6.28.10 and GCC: 4.1.2

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

part log:

AS arch/mips/lib/strlen_user.o

AS arch/mips/lib/strncpy_user.o
AS arch/mips/lib/strnlen_user.o
CC arch/mips/lib/uncached.o
AR arch/mips/lib/lib.a
LD vmlinux.o
MODPOST vmlinux.o
GEN .version
CHK include/linux/compile.h
UPD include/linux/compile.h
CC init/version.o
LD init/built-in.o
LD vmlinux
SYSMAP System.map
Building modules, stage 2.
MODPOST 398 modules

ERROR: "ar231x_gpiodev" [drivers/w1/masters/w1-gpio.ko] undefined!
ERROR: "ar231x_gpiodev" [drivers/spi/spi_gpio_old.ko] undefined!
ERROR: "ar231x_gpiodev" [drivers/spi/spi_gpio.ko] undefined!
ERROR: "ar231x_gpiodev" [drivers/input/misc/gpio_buttons.ko] undefined!
ERROR: "ar231x_gpiodev" [drivers/i2c/busses/i2c-gpio.ko] undefined!
make[6]: * [modpost] Error 1
make[5]:
* [modules] Error 2
make[5]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/build_dir/mips/atheros/linux-atheros/linux-2.6.28.10'
make[4]: * /home/geryon/programacion/waveFlight/trunk/build_dir/mips/atheros/linux-atheros/linux-2.6.28.10/.image Error 2
make[4]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/target/linux/atheros'
make[3]:
* [install] Error 2
make[3]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/target/linux'
make[2]: * [target/linux/install] Error 2
make[2]: Leaving directory `/home/geryon/programacion/waveFlight/trunk'
make[1]:
* /home/geryon/programacion/waveFlight/trunk/staging_dir/mips/atheros/target-mips_uClibc-0.9.30.1/stamp/.target_install Error 2
make[1]: Leaving directory `/home/geryon/programacion/waveFlight/trunk'
make: * [world] Error 2

Attachments (0)

Change History (3)

comment:1 in reply to: ↑ description Changed 9 years ago by guillermo@…

Replying to anonymous:

part log:

AS arch/mips/lib/strlen_user.o

AS arch/mips/lib/strncpy_user.o
AS arch/mips/lib/strnlen_user.o
CC arch/mips/lib/uncached.o
AR arch/mips/lib/lib.a
LD vmlinux.o
MODPOST vmlinux.o
GEN .version
CHK include/linux/compile.h
UPD include/linux/compile.h
CC init/version.o
LD init/built-in.o
LD vmlinux
SYSMAP System.map
Building modules, stage 2.
MODPOST 398 modules

ERROR: "ar231x_gpiodev" [drivers/w1/masters/w1-gpio.ko] undefined!
ERROR: "ar231x_gpiodev" [drivers/spi/spi_gpio_old.ko] undefined!
ERROR: "ar231x_gpiodev" [drivers/spi/spi_gpio.ko] undefined!
ERROR: "ar231x_gpiodev" [drivers/input/misc/gpio_buttons.ko] undefined!
ERROR: "ar231x_gpiodev" [drivers/i2c/busses/i2c-gpio.ko] undefined!
make[6]: * [modpost] Error 1
make[5]:
* [modules] Error 2
make[5]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/build_dir/mips/atheros/linux-atheros/linux-2.6.28.10'
make[4]: * /home/geryon/programacion/waveFlight/trunk/build_dir/mips/atheros/linux-atheros/linux-2.6.28.10/.image Error 2
make[4]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/target/linux/atheros'
make[3]:
* [install] Error 2
make[3]: Leaving directory `/home/geryon/programacion/waveFlight/trunk/target/linux'
make[2]: * [target/linux/install] Error 2
make[2]: Leaving directory `/home/geryon/programacion/waveFlight/trunk'
make[1]:
* /home/geryon/programacion/waveFlight/trunk/staging_dir/mips/atheros/target-mips_uClibc-0.9.30.1/stamp/.target_install Error 2
make[1]: Leaving directory `/home/geryon/programacion/waveFlight/trunk'
make: * [world] Error 2

Hello, I actually built successfully the atheros firmware disabling all regarding with GPIO related but GPIO_SUPPORT.-
I don't know why it gives the error above it is just when the script wich merge .config-overrides and .config-target > .config.
because of that the error shows up.
By the way, drivers/w1/masters/w1-gpio.ko exists and same for other modules too.

Perhaps it is a target/atheros related problem?, if it is so, just give me some point to start investigation.

Thanks

comment:2 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Seems to have been fixed I cannot reproduce it.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.