Modify

Opened 9 years ago

Closed 9 years ago

#5320 closed defect (fixed)

Default kernel arguments do not work on WGT634U

Reported by: Jonathan <jh-openwrt@…> Owned by: developers
Priority: normal Milestone: Kamikaze 8.09.2
Component: kernel Version: Kamikaze 8.09
Keywords: Cc:

Description

The Netgear WGT634U uses ttyS1 for the console port.

Default Netgear kernel_args (before flashing with OpenWrt):
console=ttyS1,115200 root=/dev/ram0 init=/linuxrc rw syst_size=8M

However, OpenWrt does not take any notice of the kernel_args NVRAM variable, and uses ttyS0 by default:

[root@localhost 8.09]# grep "console=ttyS0" target/linux/brcm47xx/*
target/linux/brcm47xx/config-2.6.25:CONFIG_CMDLINE="root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200"

Is there a way of updating this via the build system for the WGT634U platform? Without changing the console= string, the device isn't usable - CFE uses ttyS1. This isn't something a regular user is likely to figure out straight away.

(Unless I'm missing something simple, of course!)

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 9 years ago by KillaB

As far as the physical port is concerned I've never had a problem just using port J7.
I don't see what the problem is since CFE and OpenWrt both respond on this port.

J6 does not present a CFE as far as I know, so it wouldn't make sense to call it ttyS0.

comment:2 in reply to: ↑ 1 Changed 9 years ago by Jonathan <jh-openwrt@…>

Replying to KillaB:

As far as the physical port is concerned I've never had a problem just using port J7.
I don't see what the problem is since CFE and OpenWrt both respond on this port.

J6 does not present a CFE as far as I know, so it wouldn't make sense to call it ttyS0.

When I flash my device using the standard firmware downloaded from the OpenWrt web site, I get the following on J7:

CFE> boot -elf -fs=raw flash0.os:
Loader:elf Filesys:raw Dev:flash0.os File: Options:(null)
***************************
****  MAC Client V1.0  ****
***************************
et0macaddr value :flag =2 value=00-0f-b5-0e-07-02
et1macaddr value :flag =2 value=00-0f-b5-0e-07-03
MAC exist at least one
system ethernet mac exist and not default....
Skip mac client process.....
Loading: 0x80001000/3768 Entry at 0x80001000
Starting program at 0x80001000
Linux version 2.6.25.17 (nbd@baustelle) (gcc version 4.1.2) #16 Sun Feb 15 00:19:46 CET 2009
console [early0] enabled
CPU revision is: 00029007 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x05, vendor 0x4243)
ssb: Core 1 found: Fast Ethernet (cc 0x806, rev 0x06, vendor 0x4243)
ssb: Core 2 found: IPSEC (cc 0x80B, rev 0x01, vendor 0x4243)
ssb: Core 3 found: USB 1.1 Hostdev (cc 0x808, rev 0x02, vendor 0x4243)
ssb: Core 4 found: PCI (cc 0x804, rev 0x08, vendor 0x4243)
ssb: Core 5 found: MIPS 3302 (cc 0x816, rev 0x01, vendor 0x4243)
ssb: Core 6 found: MEMC SDRAM (cc 0x80F, rev 0x00, vendor 0x4243)
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0806, irq 2 => 2
ssb: set_irq: core 0x0804, irq 0 => 3
ssb: Sonics Silicon Backplane found at address 0x18000000
Serial init done.
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal          0 ->     8192
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0:        0 ->     8192
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
Primary instruction cache 8kB, VIPT, 2-way, linesize 16 bytes.
Primary data cache 4kB, 2-way, VIPT, no aliases, linesize 16 bytes
Synthesized clear page handler (26 instructions).
Synthesized copy page handler (46 instructions).
PID hash table entries: 128 (order: 7, 512 bytes)
console handover: boot [early0] -> real [ttyS0]

At this point it stops responding. If I move the serial cable over onto J6, I then see the rest of the startup messages, and can interact with the shell - hence my question about ttyS0 and ttyS1.

I have since rebuilt OpenWRT after changing the kernel commandline to have console=ttyS1 instead of console=ttyS0. This gets further along the boot process for me on J7, without having to use J6 at all (although I'm having other issues in building OpenWrt and it isn't actually booting into init yet)

I'm surprised my experience is different to yours - I would have expected it to just work on J7 'out of the box', as you say.

I have now downloaded a fresh copy of OpenWrt, updated it from svn, and am building a clean image to see if that makes a difference (my previous one, whilst updated from svn, was used for WRT54G development and so may have had different packages selected)

comment:3 Changed 9 years ago by Jonathan <jh-openwrt@…>

OK, now I'm confused.

I have once more flashed my router with the OpenWrt 8.09.1 image from the main web site - and now it works exactly as you describe, with just the J7 connector.

I still haven't successfully compiled my own OpenWrt image, but I really don't know why my router would print the "console handover" messages above yesterday and not today.

Sadly I don't have a router exhibiting these symptoms any more, otherwise I'd offer it for investigation so that we could get to the bottom of the issue :( Right now, everything works fine and there's no problem.

comment:4 Changed 9 years ago by nico

  • Resolution set to fixed
  • Status changed from new to closed

No new replies...

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.