Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#5290 closed defect (fixed)

"Units" Mode changed between 8.09.1 and Trunk in Busybox ?

Reported by: anonymous Owned by: nico
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: df -h AR7 BRCM2.4 Trunk Cc:

Description (last modified by nico)

Instead showing the free space in Kbytes, like in stable Branches, the Trunk shows on BRCM2.4 and AR7 the units only as Blocks, no
longer in Kbyte. The Parameter -k and -m from "df" are completly ignored, so i asume a bug in the actual busybox config. The Problem exists on uclibC 0.9.29 and 0.9.30 since a longer while.

This is new/wrong view:

root@OpenWrt:~# df -h
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2048      2048         0 100% /rom
tmpfs                     6348        48      6300   1% /tmp
tmpfs                      512         0       512   0% /dev
/dev/mtdblock4            1088       212       876  19% /jffs
mini_fo:/jffs             2048      2048         0 100% /
root@OpenWrt:~#

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by nico

  • Description modified (diff)
  • Owner changed from developers to nico

Confirmed on r16721 with busybox v1.13.4. I can't reproduce the bug with busybox v1.14.1

comment:2 Changed 9 years ago by nico

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [16723], thanks for reporting!

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.