Modify

Opened 12 years ago

Closed 12 years ago

#527 closed defect (duplicate)

dnsmasq fails starting after upgrade from asus-fw on asus wl-500-deluxe

Reported by: pittipatti@… Owned by: developers
Priority: high Milestone: 0.9/rc6
Component: base system Version:
Keywords: dnsmasq Cc:

Description

After upgrading from stock-asus-fw to openwrt whiterussian rc5 dns-masq fails to start.

The problem is, that the asus-fw stores a full ip-address as dhcp-range-startaddress (eg. 192.168.1.200) in "nvram: dhcp_start" and openwrt asumes only the last byte of the address in this nvram-variable.

It might be that the full ip is only the case after changing this address in asus-webinterface, but then it is for sure!

The result is that dnsmasq does not start!

Patrick

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by anonymous

/etc/init.d/S50dnsmasq is broken!

Line 26 should be like this:

args="-K -F $start,$end,$netmask,${lease:-12h}"

And $end does not get calculated!

comment:2 Changed 12 years ago by mbm

  • Resolution set to duplicate
  • Status changed from new to closed

dupe: #477, #542, #550

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.