Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#5126 closed defect (fixed)

Kernel 2.6.28.10 compile stops due to config questions (SSB_BLOCKIO, RTC_HCTOSYS_DEVICE)

Reported by: Maddes <maddes_trac@…> Owned by: kaloz
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

Trunk: r15830
Feed "packages": same revision as trunk, all packages installed
Feed "luci": r4519, all packages installed

Build Environment: Debian 5.0

Target System: Marvel Orion
Target Image: SquashFS image
Kernel: 2.6.28
Global build settings: Select all packages by default
Call: make V=99

The kernel does not compile automatically as there pops up two questions/infos which have to be answered or accepted (lines with NEW mark).
When make is called without V=99 then it just sits there and waits.
This is a problem for newbies that will wait forever for the compilation to finish.

* Sonics Silicon Backplane
*
Sonics Silicon Backplane support (SSB) [M/n/y/?] m
add SSB_BLOCKIO support (SSB_BLOCKIO) [N/y] (NEW)
* Real Time Clock
*
Real Time Clock (RTC_CLASS) [Y/n/m/?] y
  Set system time from RTC on startup and resume (RTC_HCTOSYS) [Y/n/?] y
    RTC used to set the system time (RTC_HCTOSYS_DEVICE) [rtc0] (NEW)

Attachments (0)

Change History (11)

comment:1 Changed 9 years ago by Nuno Silva <nuno@…>

I can confirm this (building all packages for TRENDNet TEW-652BRP).

Last few lines of make V=99:

scripts/kconfig/conf -o arch/mips/Kconfig
.config:2061:warning: symbol value 'm' invalid for SND_PPC
*

  • Restart config...

*
*

  • Sonics Silicon Backplane

*
Sonics Silicon Backplane support (SSB) [M/n/y/?] m
add SSB_BLOCKIO support (SSB_BLOCKIO) [N/y] (NEW)

Regards,
Nuno Silva

comment:2 Changed 9 years ago by cshore@…

This also occurs with 2.6.27

comment:3 Changed 9 years ago by kaloz

  • Owner changed from developers to kaloz
  • Status changed from new to assigned

The separate rtc driver was causing one of the problems, b43's pcmcia support caused the other.

Please svn up and retry.

comment:4 Changed 9 years ago by Maddes <maddes_trac@…>

Updated to current r15869.
Just to be on the safe side I issued "make distclean", "rm .config" and "make menuconfig".

Still one config question left:

* Sonics Silicon Backplane
*
Sonics Silicon Backplane support (SSB) [M/n/y/?] m
add SSB_BLOCKIO support (SSB_BLOCKIO) [N/y] (NEW)

I see in r15857 that you removed SSB_BLOCKIO for brcm63xx 2.6.27 (was added in r15856), but didn't see it added to any other file.

comment:5 Changed 9 years ago by kaloz

BLOCKIO should be enabled only if b43 PIO is used, which gets enabled only if b43 pcmcia support is enabled, so it should be disabled by the mac80211 changes.. hmz..

comment:6 Changed 9 years ago by kaloz

Try adding SSB_BLOCKIO=n to the mac80211 Makefile where b43's PCMCIA is diabled (line 416).

comment:7 Changed 9 years ago by Maddes <maddes_trac@…>

If I do not select any additional package then the question is gone, even without your last suggestion:
Issued "make clean", "rm .config" and "make menuconfig".
Then only selected target Marvell Orion, no additional packages, then the question is gone.

But if I choose Select all packages by default it comes back again.
All packages are selected because I provide a temporary repository for Marvell Orion until it's back on openwrt.org.
So a package is the reason for SSB being enabled.
Maybe somewhere in a package it is unset.
Even with your last suggestion:

Index: package/mac80211/Makefile
===================================================================
--- package/mac80211/Makefile   (revision 15869)
+++ package/mac80211/Makefile   (working copy)
@@ -413,7 +413,7 @@
        CONFIG_MAC80211_RC_MINSTREL=y \
        CONFIG_MAC80211_LEDS=$(CONFIG_LEDS_TRIGGERS) \
        CONFIG_MAC80211_DEBUGFS=$(CONFIG_DEBUG_FS) \
-       CONFIG_B43_PCMCIA=n CONFIG_B43_PIO=n \
+       CONFIG_B43_PCMCIA=n CONFIG_B43_PIO=n CONFIG_SSB_BLOCKIO=n \
        $(if $(CONFIG_PCI),CONFIG_B43_PCI_AUTOSELECT=y,CONFIG_B43_PCI_AUTOSELECT=n) \
        $(if $(CONFIG_PCI),CONFIG_B43_PCICORE_AUTOSELECT=y,CONFIG_B43_PCICORE_AUTOSELECT=n) \
        $(if $(CONFIG_PCI),CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=y,CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=n) \

comment:8 Changed 9 years ago by Maddes <maddes_trac@…>

Recognized that mac80211/Makefile also defines SSB CONFIG variables between lines 394 and 432, maybe these have to be adopted too.
Also kmod-ssb is used on line 365.
Just my two cents.

comment:9 Changed 9 years ago by Maddes <maddes_trac@…>

Selected all packages once again, then disabled kmod-b43 plus kmod-b43legacy (under Kernel Mods -> Wireless) and kmod-ssb (Kernel Mods -> Others).
No config question popped up.

So the issue has been reduced to the case where kmod-ssb is enabled.

comment:10 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [15926].

comment:11 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.