Modify

Opened 12 years ago

Closed 12 years ago

#512 closed defect (wontfix)

lighthttpd mod_proxy error: proxy.state 3

Reported by: plu@… Owned by: nico
Priority: normal Milestone: 0.9/rc6
Component: packages Version:
Keywords: Cc:

Description

Hi!

You can reproduce this error this way:

  1. ipkg install lighttpd
  2. ipkg install lighttpd-mod-proxy
  3. example config of /etc/lighttpd.conf (only the modified parts):

server.modules = (

"mod_proxy"

)

$HTTPhost? == "www.example.com" {

proxy.balance = "hash"
proxy.server = ( "" => ( ( "host" => "192.168.1.10", "port" => 80 ) ) )

}

At 192.168.1.10 is some apache webserver running on port 80. The whole thing is working very nice until 192.168.1.10 goes down. If you send a request to www.example.com while the apache is not running on 192.168.1.10 the lighttpd on openwrt gets a very high cpu usage and is producing a lot of those errors:

Apr 24 19:54:48 (none) kern.err lighttpd: (mod_proxy.c.1088) unhandled proxy.state 3
Apr 24 19:54:48 (none) kern.err lighttpd: (mod_proxy.c.918) error: unexpected close of proxy connection for (no proxy process on host: 192.168.1.10, port: 80 ?)

If you restart the apache at 192.168.1.10 again, the lighttpd doesnt stop using that much cpu.

My router is a linksys wrt-54-gl.

root@router:~# uname -a
Linux router 2.4.30 #1 Sun Mar 26 19:02:04 CEST 2006 mips unknown

If you need any other informations, feel free to mail me at plu@…

cheers and thanks in advance, plu

Attachments (0)

Change History (4)

comment:1 Changed 12 years ago by kaloz

  • Milestone set to 1.0-rc6

comment:2 Changed 12 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to assigned

Can you reproduce the bug with the latest lighttpd (v1.4.11), that can be found in the backports repository?

comment:3 Changed 12 years ago by plu@…

I have just tested v1.4.11 from backports and i can't reproduce the bug there. Thanks for your time & help!

comment:4 Changed 12 years ago by nico

  • Resolution set to wontfix
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.