Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#5060 closed defect (duplicate)

Not build opkg package in gcc 4.4.0

Reported by: sav Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: libtool Cc:

Description (last modified by nico)

/bin/bash ../libtool --tag=CC --mode=link mipsel-openwrt-linux-uclibc-gcc -Wall -Werror -DHOST_CPU_STR=\"mipsel\" -DBUILD_CPU=x86_64 -DLIBDIR=\"/usr/lib\" -DOPKGLIBDIR=\"/usr/lib\" -DDATADIR=\"/usr/share\" -I..    -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -fpic -Wno-array-bounds -I/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/include -I/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/target-mipsel_uClibc-0.9.30.1/include  -L/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/lib -L/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/lib -L/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/lib -L/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/target-mipsel_uClibc-0.9.30.1/lib -L/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/usr/lib -L/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/toolchain-mipsel_gcc-4.4.0_uClibc-0.9.30.1/lib -L/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/lib -L/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/target-mipsel_uClibc-0.9.30.1/lib -Wl,-rpath-link,/home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/target-mipsel_uClibc-0.9.30.1/usr/lib -o libopkg.la -rpath /usr/lib -export-symbols-regex "^opkg_.*" args.lo libopkg.lo user.lo opkg_state.lo opkg.lo opkg_cmd.lo opkg_configure.lo opkg_download.lo opkg_install.lo opkg_upgrade.lo opkg_remove.lo opkg_conf.lo opkg_utils.lo pkg.lo pkg_depends.lo pkg_extract.lo hash_table.lo pkg_hash.lo pkg_parse.lo pkg_vec.lo file_util.lo opkg_message.lo md5.lo sprintf_alloc.lo str_util.lo xregex.lo xsystem.lo conffile.lo conffile_list.lo nv_pair.lo nv_pair_list.lo pkg_dest.lo pkg_dest_list.lo pkg_src.lo pkg_src_list.lo str_list.lo void_list.lo ../libbb/libbb.la   
generating symbol list for `libopkg.la'
mipsel-openwrt-linux-uclibc-nm  .libs/args.o .libs/libopkg.o .libs/user.o .libs/opkg_state.o .libs/opkg.o .libs/opkg_cmd.o .libs/opkg_configure.o .libs/opkg_download.o .libs/opkg_install.o .libs/opkg_upgrade.o .libs/opkg_remove.o .libs/opkg_conf.o .libs/opkg_utils.o .libs/pkg.o .libs/pkg_depends.o .libs/pkg_extract.o .libs/hash_table.o .libs/pkg_hash.o .libs/pkg_parse.o .libs/pkg_vec.o .libs/file_util.o .libs/opkg_message.o .libs/md5.o .libs/sprintf_alloc.o .libs/str_util.o .libs/xregex.o .libs/xsystem.o .libs/conffile.o .libs/conffile_list.o .libs/nv_pair.o .libs/nv_pair_list.o .libs/pkg_dest.o .libs/pkg_dest_list.o .libs/pkg_src.o .libs/pkg_src_list.o .libs/str_list.o .libs/void_list.o  ../libbb/.libs/libbb.a |  | /home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/host/bin/sed 's/.* //' | sort | uniq > .libs/libopkg.exp
../libtool: eval: line 4350: syntax error near unexpected token `|'
../libtool: eval: line 4350: `mipsel-openwrt-linux-uclibc-nm  .libs/args.o .libs/libopkg.o .libs/user.o .libs/opkg_state.o .libs/opkg.o .libs/opkg_cmd.o .libs/opkg_configure.o .libs/opkg_download.o .libs/opkg_install.o .libs/opkg_upgrade.o .libs/opkg_remove.o .libs/opkg_conf.o .libs/opkg_utils.o .libs/pkg.o .libs/pkg_depends.o .libs/pkg_extract.o .libs/hash_table.o .libs/pkg_hash.o .libs/pkg_parse.o .libs/pkg_vec.o .libs/file_util.o .libs/opkg_message.o .libs/md5.o .libs/sprintf_alloc.o .libs/str_util.o .libs/xregex.o .libs/xsystem.o .libs/conffile.o .libs/conffile_list.o .libs/nv_pair.o .libs/nv_pair_list.o .libs/pkg_dest.o .libs/pkg_dest_list.o .libs/pkg_src.o .libs/pkg_src_list.o .libs/str_list.o .libs/void_list.o  ../libbb/.libs/libbb.a |  | /home/sysadmin/wl500/OpenWrt/build-4.4.0/staging_dir/host/bin/sed 's/.* //' | sort | uniq > .libs/libopkg.exp'
make[6]: *** [libopkg.la] Error 1
make[6]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build-4.4.0/build_dir/target-mipsel_uClibc-0.9.30.1/opkg-4564/libopkg'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build-4.4.0/build_dir/target-mipsel_uClibc-0.9.30.1/opkg-4564/libopkg'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build-4.4.0/build_dir/target-mipsel_uClibc-0.9.30.1/opkg-4564'
make[3]: *** [/home/sysadmin/wl500/OpenWrt/build-4.4.0/build_dir/target-mipsel_uClibc-0.9.30.1/opkg-4564/.built] Error 2
make[3]: Leaving directory `/home/sysadmin/wl500/OpenWrt/build-4.4.0/package/opkg'
make[2]: *** [package/opkg/compile] Error 2

Attachments (1)

build.log.gz (9.3 KB) - added by sav 9 years ago.
build.log

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by sav

build.log

comment:1 Changed 9 years ago by nico

  • Description modified (diff)
  • Keywords libtool added

comment:2 Changed 9 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5022, this is the same issue.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.