Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#5036 closed defect (worksforme)

sqlite3 does not compile

Reported by: wurst Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

... with r15544 x86

make[4]: Entering directory `/home/wurst/openwrt/x86/build_dir/target-i386_uClibc-0.9.29/sqlite-3.6.13'
sed -e s/--VERS--/3.6.13/ ./src/sqlite.h.in | \
	sed -e s/--VERSION-NUMBER--/3006013/ >sqlite3.h
gcc  -g -o lemon ./tool/lemon.c
cp ./tool/lempar.c .
cp ./src/parse.y .
./lemon -DSQLITE_OMIT_LOAD_EXTENSION=1  parse.y
mv parse.h parse.h.temp
gawk -f ./addopcodes.awk parse.h.temp >parse.h
cat parse.h ./src/vdbe.c | gawk -f ./mkopcodeh.awk >opcodes.h
./libtool --mode=compile --tag=CC i486-openwrt-linux-uclibc-gcc  -I/home/wurst/openwrt/x86/staging_dir/target-i386_uClibc-0.9.29/usr/include -I/home/wurst/openwrt/x86/staging_dir/target-i386_uClibc-0.9.29/include  -O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -fpic -DSQLITE_OS_UNIX=1 -I. -I./src -D_HAVE_SQLITE_CONFIG_H -DNDEBUG   -DSQLITE_THREADSAFE=1 -DSQLITE_THREAD_OVERRIDE_LOCK=-1 -DSQLITE_OMIT_LOAD_EXTENSION=1   -DSQLITE_TEMP_STORE=1 -c ./src/alter.c
libtool: compile:  i486-openwrt-linux-uclibc-gcc -I/home/wurst/openwrt/x86/staging_dir/target-i386_uClibc-0.9.29/usr/include -I/home/wurst/openwrt/x86/staging_dir/target-i386_uClibc-0.9.29/include -O2 -pipe -march=i486 -funit-at-a-time -fhonour-copts -fpic -DSQLITE_OS_UNIX=1 -I. -I./src -D_HAVE_SQLITE_CONFIG_H -DNDEBUG -DSQLITE_THREADSAFE=1 -DSQLITE_THREAD_OVERRIDE_LOCK=-1 -DSQLITE_OMIT_LOAD_EXTENSION=1 -DSQLITE_TEMP_STORE=1 -c ./src/alter.c  -fPIC -DPIC -o .libs/alter.o
In file included from ./src/sqliteInt.h:602,
                 from ./src/alter.c:17:
./src/pager.h:103: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
In file included from ./src/alter.c:17:
./src/sqliteInt.h:2188: error: expected specifier-qualifier-list before 'sqlite3_mem_methods'
./src/sqliteInt.h:2326: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
./src/sqliteInt.h:2692: error: expected ')' before '*' token
./src/sqliteInt.h:2693: error: expected ')' before '*' token
make[4]: *** [alter.lo] Error 1
make[4]: Leaving directory `/home/wurst/openwrt/x86/build_dir/target-i386_uClibc-0.9.29/sqlite-3.6.13'
make[3]: *** [/home/wurst/openwrt/x86/build_dir/target-i386_uClibc-0.9.29/sqlite-3.6.13/.built] Error 2
make[3]: Leaving directory `/home/wurst/openwrt/x86/feeds/packages/libs/sqlite3'
make[2]: *** [package/feeds/packages/sqlite3/compile] Error 2
make[2]: Leaving directory `/home/wurst/openwrt/x86'
make[1]: *** [/home/wurst/openwrt/x86/staging_dir/target-i386_uClibc-0.9.29/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/wurst/openwrt/x86'
make: *** [world] Fehler 2

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this bug.

comment:2 Changed 9 years ago by Felix.Braun@…

I have the same problem. Maybe the error only ocurrs with gcc 4.3.3 (which I am using).

comment:3 Changed 9 years ago by Raphaël HUCK <raphael.huck@…>

Does not work for me either... same problem with new 3.6.14

in ./src/pager.h:103

sqlite3_backup **sqlite3PagerBackupPtr(Pager*);

but sqlite3_backup is defined in src/backup.c:29

struct sqlite3_backup {
...
};

comment:4 Changed 9 years ago by Raphaël HUCK <raphael.huck@…>

mips-linux-uclibc-gcc
gcc version 4.2.4

comment:5 Changed 9 years ago by Raphaël HUCK <raphael.huck@…>

see #5131

comment:6 Changed 9 years ago by florian

Fixed with [15893].

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.