Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#5004 closed defect (worksforme)

base-files doesn't compile due to missing .so files

Reported by: Maddes <maddes_trac@…> Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Revision: r15397
Build Environment: Debian 5.0r0
Target: Marvel Orion, SquashFS image
Call: make V=99

Error message:

make[3]: Entering directory `/home/openwrt/kamikaze-trunk/package/base-files'
install -d -m0755 /home/openwrt/kamikaze-trunk/build_dir/linux-orion_generic/base-files/ipkg/libc/lib
for file in ld-uClibc libc libcrypt libdl libm libnsl libresolv libuClibc libutil; do cp -fpR /home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/$file.so.* /home/openwrt/kamikaze-trunk/build_dir/linux-orion_generic/base-files/ipkg/libc/lib/; cp -fpR /home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/$file-.so /home/openwrt/kamikaze-trunk/build_dir/linux-orion_generic/base-files/ipkg/libc/lib/; done
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/ld-uClibc-.so': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libc-.so': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libcrypt-.so': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libdl-.so': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libm-.so': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libnsl-.so': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libresolv-.so': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libuClibc.so.*': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libuClibc-.so': No such file or directory
cp: cannot stat `/home/openwrt/kamikaze-trunk/staging_dir/toolchain-arm_gcc-4.1.2_uClibc-0.9.29/lib/libutil-.so': No such file or directory
make[3]: *** [/home/openwrt/kamikaze-trunk/bin/packages/target-arm_uClibc-0.9.29/libc_0.9.29-18_arm.ipk] Error 1
make[3]: Leaving directory `/home/openwrt/kamikaze-trunk/package/base-files'

This makes it impossible to compile even the smallest build.

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

This happened since [15368]. I also had this issue which should be fixed with a make distclean and then rebuild your trunk.

comment:2 Changed 9 years ago by Maddes <maddes_trac@…>

Thought that "make clean" was enough, didn't know about "make distclean", that helped. Thanks.
Will check if other build problems were also caused by this.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.