Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#5003 closed defect (fixed)

[rdc] Kernel Panic after upgrading to trunk

Reported by: anonymous Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

I've upgraded to trunk due to florian bumping the default kernel from 2.6.24.7 to 2.6.28.9 (awesome!) but I've run into the issue on bootup:

TCP reno registered
NET: Registered protocol family 1
Unpacking initramfs...<0>Kernel panic - not syncing: bad gzip magic numbers

I'm using the default config, building for the RDC321x SoC with the target AR525w.

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by anonymous

if I add ramdisk support in kernel_menuconfig then I can boot successfully. Dirty.

comment:2 Changed 9 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

Which specific kernel configuration option did you enable ? I could not reproduce such an error while testing on ar525w.

comment:3 Changed 9 years ago by anonymous

Hi, using the default config-2.6.28 and adding

CONFIG_BLK_DEV_RAM=y
CONFIG_BLK_DEV_RAM_COUNT=16
CONFIG_BLK_DEV_RAM_SIZE=4096

I was able to boot completely and fully.

comment:4 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [15532], this was indeed set in the 2.6.24 configuration. Thanks !

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.