Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4995 closed defect (worksforme)

Compilation error in qolyester

Reported by: Daniel Dickinson <cshore@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

qolyester build fails with the following messages:

 -C /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/qolyester-20090302/.. -xf - 
ls: cannot access ./patches: No such file or directory
touch /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/qolyester-20090302/.prepared_0b2d10b6cbda60c4c94be5cd83a17c4a
(cd /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/qolyester-20090302/./; if [ -x ./configure ]; then /usr/bin/find /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/qolyester-20090302/ -name config.guess | xargs -r chmod u+w; /usr/bin/find /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/qolyester-20090302/ -name config.guess | xargs -r -n1 cp /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/scripts/config.guess; /usr/bin/find /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/qolyester-20090302/ -name config.sub | xargs -r chmod u+w; /usr/bin/find /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/qolyester-20090302/ -name config.sub | xargs -r -n1 cp /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/scripts/config.sub; AR=mips-openwrt-linux-uclibc-ar AS="mips-openwrt-linux-uclibc-gcc -c -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts" LD=mips-openwrt-linux-uclibc-ld NM=mips-openwrt-linux-uclibc-nm CC="mips-openwrt-linux-uclibc-gcc" GCC="mips-openwrt-linux-uclibc-gcc" CXX="mips-openwrt-linux-uclibc-g++" RANLIB=mips-openwrt-linux-uclibc-ranlib STRIP=mips-openwrt-linux-uclibc-strip OBJCOPY=mips-openwrt-linux-uclibc-objcopy OBJDUMP=mips-openwrt-linux-uclibc-objdump SIZE=mips-openwrt-linux-uclibc-size CFLAGS="-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts " CXXFLAGS="-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts " CPPFLAGS="-I/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/usr/include -I/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/include " LDFLAGS="-L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/toolchain-mips_gcc-4.1.2_uClibc-0.9.29/usr/lib -L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/toolchain-mips_gcc-4.1.2_uClibc-0.9.29/lib -L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/usr/lib -L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/lib "   ./configure --target=mips-openwrt-linux --host=mips-openwrt-linux --build=i486-linux-gnu --program-prefix="" --program-suffix="" --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/lib --sysconfdir=/etc --datadir=/usr/share --localstatedir=/var --mandir=/usr/man --infodir=/usr/info --disable-nls ; fi; )
configure: loading site script /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/include/site/mips-openwrt-linux-uclibc
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for mips-openwrt-linux-strip... mips-openwrt-linux-uclibc-strip
checking for style of include used by make... GNU
checking for C++ compiler default output file name... 
configure: error: C++ compiler cannot create executables
See `config.log' for more details.
make[3]: *** [/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/qolyester-20090302/.configured] Error 77
make[3]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/feeds/packages/net/qolyester'
make[2]: *** [package/feeds/packages/qolyester/compile] Error 2
make[2]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt'
make[1]: *** [/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt'
make: *** [world] Error 2

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this build error, make sure you did resolve the libnotimpl dependency.

comment:2 Changed 9 years ago by nico

Fixed in [15445]

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.