Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4993 closed defect (duplicate)

Compilation error in pycairo

Reported by: Daniel Dickinson <cshore@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: libtool Cc:

Description

Build of pycairo fails with the following error messages:

mv -f .deps/_cairo_la-cairomodule.Tpo .deps/_cairo_la-cairomodule.Plo
/bin/sh ../libtool --tag=CC   --mode=link mips-openwrt-linux-uclibc-gcc  -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts  -std=c99 -Wall -module -avoid-version -export-symbols-regex init_cairo -L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/toolchain-mips_gcc-4.1.2_uClibc-0.9.29/usr/lib -L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/toolchain-mips_gcc-4.1.2_uClibc-0.9.29/lib -L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/usr/lib -L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/lib  -o _cairo.la -rpath /usr/lib/python2.6/site-packages/cairo _cairo_la-pycairo-context.lo _cairo_la-pycairo-font.lo _cairo_la-pycairo-matrix.lo _cairo_la-pycairo-path.lo _cairo_la-pycairo-pattern.lo _cairo_la-pycairo-surface.lo _cairo_la-cairomodule.lo -L/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/usr//lib -lcairo
generating symbol list for `_cairo.la'
mips-openwrt-linux-uclibc-nm  .libs/_cairo_la-pycairo-context.o .libs/_cairo_la-pycairo-font.o .libs/_cairo_la-pycairo-matrix.o .libs/_cairo_la-pycairo-path.o .libs/_cairo_la-pycairo-pattern.o .libs/_cairo_la-pycairo-surface.o .libs/_cairo_la-cairomodule.o  |  | /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/host/bin/sed 's/.* //' | sort | uniq > .libs/_cairo.exp
../libtool: eval: line 4350: syntax error near unexpected token `|'
../libtool: eval: line 4350: `mips-openwrt-linux-uclibc-nm  .libs/_cairo_la-pycairo-context.o .libs/_cairo_la-pycairo-font.o .libs/_cairo_la-pycairo-matrix.o .libs/_cairo_la-pycairo-path.o .libs/_cairo_la-pycairo-pattern.o .libs/_cairo_la-pycairo-surface.o .libs/_cairo_la-cairomodule.o  |  | /home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/host/bin/sed 's/.* //' | sort | uniq > .libs/_cairo.exp'
make[6]: *** [_cairo.la] Error 1
make[6]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/pycairo-1.8.0/cairo'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/pycairo-1.8.0'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/pycairo-1.8.0'
make[3]: *** [/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/build_dir/target-mips_uClibc-0.9.29/pycairo-1.8.0/.built] Error 2
make[3]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/feeds/packages/lang/pycairo'
make[2]: *** [package/feeds/packages/pycairo/compile] Error 2
make[2]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt'
make[1]: *** [/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt/staging_dir/target-mips_uClibc-0.9.29/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/daniel/Projects/openwrt-comtrend/kamikaze-8.09-cshore/openwrt'
make: *** [world] Error 2

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by nico

  • Keywords libtool added

comment:2 Changed 9 years ago by lars

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #5022

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.