Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4988 closed defect (duplicate)

D-Link DIR-320 fails to access jffs

Reported by: marco_borra@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: Cc:

Description

Hi,
my D-Link DIR-320 seem unable to access jffs.
I flashed latest trunk in rom and re-runned firstboot script.
telnet is ok but I can't edit files nor list /jffs
log is attached.

Thanks a lot
Marco Borra

BusyBox v1.11.3 (2009-04-20 19:43:09 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_

| |.-----.-----.-----.| | | |.----.| |_

| - |_
_ | -| | | _ _|
|_||| ||

|| W I R E L E S S F R E E D O M

KAMIKAZE (bleeding edge, r15336) -------------------

  • 10 oz Vodka Shake well with ice and strain
  • 10 oz Triple sec mixture into 10 shot glasses.
  • 10 oz lime juice Salute!

---------------------------------------------------

root@OpenWrt:/# dmesg
Linux version 2.6.28.9 (marco@…) (gcc version 4.1.2) #1 Wed Apr 22 17:36:09 CEST 2009
CPU revision is: 00029029 (Broadcom BCM3302)
ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x14, vendor 0x4243)
ssb: Core 1 found: Fast Ethernet (cc 0x806, rev 0x09, vendor 0x4243)
ssb: Core 2 found: MIPS 3302 (cc 0x816, rev 0x08, vendor 0x4243)
ssb: Core 3 found: USB 2.0 Host (cc 0x819, rev 0x02, vendor 0x4243)
ssb: Core 4 found: MEMC SDRAM (cc 0x80F, rev 0x04, vendor 0x4243)
ssb: Core 5 found: IEEE 802.11 (cc 0x812, rev 0x0D, vendor 0x4243)
ssb: Core 6 found: Roboswitch (cc 0x81C, rev 0x02, vendor 0x4243)
ssb: Found rev 0 PMU (capabilities 0x04A63400)
ssb: Initializing MIPS core...
ssb: set_irq: core 0x0806, irq 2 => 2
ssb: set_irq: core 0x0819, irq 4 => 3
ssb: set_irq: core 0x0812, irq 0 => 4
ssb: Sonics Silicon Backplane found at address 0x18000000
Serial init done.
Determined physical RAM map:

memory: 02000000 @ 00000000 (usable)

Initrd not found or empty - disabling initrd
Zone PFN ranges:

Normal 0x00000000 -> 0x00002000

Movable zone start PFN for each node
early_node_map[1] active PFN ranges

0: 0x00000000 -> 0x00002000

On node 0 totalpages: 8192
free_area_init_node: node 0, pgdat 80250f40, node_mem_map 81000000

Normal zone: 64 pages used for memmap
Normal zone: 0 pages reserved
Normal zone: 8128 pages, LIFO batch:0
Movable zone: 0 pages used for memmap

Built 1 zonelists in Zone order, mobility grouping on. Total pages: 8128
Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
Primary instruction cache 16kB, VIPT, 4-way, linesize 16 bytes.
Primary data cache 16kB, 2-way, VIPT, cache aliases, linesize 16 bytes
PID hash table entries: 128 (order: 7, 512 bytes)
console [ttyS0] enabled
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Memory: 29832k/32768k available (2054k kernel code, 2936k reserved, 318k data, 128k init, 0k highmem)
Calibrating delay loop... 239.61 BogoMIPS (lpj=479232)
Mount-cache hash table entries: 512
net_namespace: 480 bytes
NET: Registered protocol family 16
Switched to high resolution mode on CPU 0
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
NET: Registered protocol family 1
detected lzma initramfs
initramfs: LZMA lc=1,lp=2,pb=2,origSize=512
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY) © 2001-2006 Red Hat, Inc.
msgmni has been set to 58
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver2 ports, IRQ sharing enabled
serial8250: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
serial8250.0: ttyS0 at MMIO 0xb8000300 (irq = 3) is a 16550A
serial8250.0: ttyS1 at MMIO 0xb8000400 (irq = 3) is a 16550A
b44.c:v2.0
eth0: Broadcom 44xx/47xx 10/100BaseT Ethernet 00:90:4c:c0:00:01
flash init: 0x1c000000 0x02000000
Physically mapped flash: Found 2 x8 devices at 0x0 in 16-bit bank
Physically mapped flash: Found an alias at 0x800000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1000000 for the chip at 0x0
Physically mapped flash: Found an alias at 0x1800000 for the chip at 0x0

Amd/Fujitsu Extended Query Table at 0x0040

Physically mapped flash: Swapping erase regions for broken CFI table.
number of CFI chips: 1
cfi_cmdset_0002: Disabling erase-suspend-program due to code brokenness.
Flash device: 0x800000 at 0x1fc00000
bootloader size: 262144
Updating TRX offsets and length:
old trx = [0x0000001c, 0x0000090c, 0x000bfc00], len=0x00241000 crc32=0x2174cd19
new trx = [0x0000001c, 0x0000090c, 0x000bfc00], len=0x000bfc00 crc32=0x3bf6c263
erase of region [0x40000, 0x20000] on "Physically mapped flash" failed
Done
Creating 4 MTD partitions on "Physically mapped flash":
0x00000000-0x00040000 : "cfe"
0x00040000-0x007e0000 : "linux"
0x000ffc00-0x007e0000 : "rootfs"
mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=280000, len=560000
0x00280000-0x007e0000 : "rootfs_data"
0x007e0000-0x00800000 : "nvram"
TCP vegas registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@…>
All bugs added by David S. Miller <davem@…>
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 128k freed
Please be patient, while OpenWrt loads ...
Algorithmics/MIPS FPU Emulator v1.5
diag: Router model not detected.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
roboswitch: Probing device eth0: found!
b44: eth0: powering down PHY
mini_fo: using base directory: /
mini_fo: using storage directory: /tmp/root
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
device eth0.0 entered promiscuous mode
device eth0 entered promiscuous mode
br-lan: topology change detected, propagating
br-lan: port 1(eth0.0) entering forwarding state
cfg80211: Using static regulatory domain info
cfg80211: Regulatory domain: US

(start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
(2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2700 mBm)
(5170000 KHz - 5190000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
(5190000 KHz - 5210000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
(5210000 KHz - 5230000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
(5230000 KHz - 5330000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
(5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 3000 mBm)

cfg80211: Calling CRDA for country: US
br-lan: port 1(eth0.0) entering disabled state
br-lan: topology change detected, propagating
br-lan: port 1(eth0.0) entering forwarding state
b43-phy0: Broadcom 5354 WLAN found (core revision 13)
b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 6, Type 5, Revision 0)
b43: probe of ssb0:3 failed with error -122
Broadcom 43xx driver loaded [ Features: PLR, Firmware-ID: FW13 ]
Broadcom 43xx-legacy driver loaded [ Features: LRD, Firmware-ID: FW10 ]
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (512 buckets, 2048 max)
jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
jffs2_build_filesystem(): unlocking the mtd device... done.
jffs2_build_filesystem(): erasing all blocks after the end marker... <4>Erase at 0x00540000 failed immediately: errno -5
Erase at 0x00520000 failed immediately: errno -5
Erase at 0x00500000 failed immediately: errno -5
Erase at 0x004e0000 failed immediately: errno -5
Erase at 0x004c0000 failed immediately: errno -5
Erase at 0x004a0000 failed immediately: errno -5
Erase at 0x00480000 failed immediately: errno -5
Erase at 0x00460000 failed immediately: errno -5
Erase at 0x00440000 failed immediately: errno -5
Erase at 0x00420000 failed immediately: errno -5
Erase at 0x00400000 failed immediately: errno -5
Erase at 0x003e0000 failed immediately: errno -5
Erase at 0x003c0000 failed immediately: errno -5
Erase at 0x003a0000 failed immediately: errno -5
Erase at 0x00380000 failed immediately: errno -5
Erase at 0x00360000 failed immediately: errno -5
Erase at 0x00340000 failed immediately: errno -5
Erase at 0x00320000 failed immediately: errno -5
Erase at 0x00300000 failed immediately: errno -5
Erase at 0x002e0000 failed immediately: errno -5
Erase at 0x002c0000 failed immediately: errno -5
Erase at 0x002a0000 failed immediately: errno -5
Erase at 0x00280000 failed immediately: errno -5
Erase at 0x00260000 failed immediately: errno -5
Erase at 0x00240000 failed immediately: errno -5
Erase at 0x00220000 failed immediately: errno -5
Erase at 0x00200000 failed immediately: errno -5
Erase at 0x001e0000 failed immediately: errno -5
Erase at 0x001c0000 failed immediately: errno -5
Erase at 0x001a0000 failed immediately: errno -5
Erase at 0x00180000 failed immediately: errno -5
Erase at 0x00160000 failed immediately: errno -5
Erase at 0x00140000 failed immediately: errno -5
Erase at 0x00120000 failed immediately: errno -5
Erase at 0x00100000 failed immediately: errno -5
Erase at 0x000e0000 failed immediately: errno -5
Erase at 0x000c0000 failed immediately: errno -5
Erase at 0x000a0000 failed immediately: errno -5
Erase at 0x00080000 failed immediately: errno -5
Erase at 0x00060000 failed immediately: errno -5
Erase at 0x00040000 failed immediately: errno -5
Erase at 0x00020000 failed immediately: errno -5
Erase at 0x00000000 failed immediately: errno -5
done.
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
mini_fo: build_sto_structure: failed to create storage dir [1].
mini_fo: get_neg_sto_dentry: ERROR building sto structure.
ASSERTION FAILED: src != NULL at fs/mini_fo/mini_fo.h:403 (fist_copy_attr_times)
CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 800e75b8, ra == 800e75b8
Oops#1:
Cpu 0
$ 0 : 00000000 10009800 00000054 00000001
$ 4 : 80245c40 000025d1 00000001 80292b80
$ 8 : 00000001 80240000 80280000 80290000
$12 : 80280000 00000000 2ab025b0 00403bee
$16 : 00000000 8188020c ffffffff 818969a0
$20 : 7fefaf92 00000000 00407390 00000000
$24 : 81dfdcd8 000186a0
$28 : 81dfc000 81dfde68 00000000 800e75b8
Hi : 00000077
Lo : ceda6000
epc : 800e75b8 0x800e75b8

Not tainted

ra : 800e75b8 0x800e75b8
Status: 10009803 KERNEL EXL IE
Cause : 0080000c
BadVA : 00000000
PrId : 00029029 (Broadcom BCM3302)
Modules linked in: nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ipt_REJECT xt_TCPMSS ipt_LOG xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc b43legacy b43 mac80211 cfg80211 crc_ccitt arc4 aes_generic deflate ecb cbc crypto_hash cryptomgr crypto_blkcipher aead crypto_algapi switch_robo switch_core
Process mv (pid: 829, threadinfo=81dfc000, task=81c44998, tls=00000000)
Stack : 818969a0 8021fa28 8021f9e4 00000193 8020c85c ffffffeb fffffff0 8188020c

818969a0 00000000 80093b74 ffffffeb 81dfdecc ffffffeb 7fefad98 00000000
81896580 00000000 8188020c 80095f3c 00000000 8008df90 81c0cea0 81881704
81c2c000 81c0cea0 81881704 3b3f7b79 00000015 81c2c00e 00000000 00000000
00000000 00000000 000001c9 00000000 00000028 188f13c4 00000028 188f13c4
...

Call Trace:[<80093b74>] 0x80093b74
[<80095f3c>] 0x80095f3c
[<8008df90>] 0x8008df90
[<800031d0>] 0x800031d0

Code: 24070193 0c00b33f afa20010 <a2000000> 8e02005c 8e030048 8e04004c 8e050050 8e060054
root@OpenWrt:/#

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by agb

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #4729

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.