Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4984 closed defect (invalid)

b43 driver can't change mode if interface is up

Reported by: andrew@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,

My WRT54GS isn't able to set the mode of the wifi card with the b43 driver on system startup to ad-hoc.

If I try and change the mode by hand this happens:

root@2fantail:~# iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"OpenWrt"  
          Mode:Managed  Frequency:2.432 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@2fantail:~# iwconfig wlan0 mode ad-hoc
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Device or resource busy.
root@2fantail:~# 

I need to down the interface first, then change the mode.

The driver should probably be able to change the mode without needing to run ifconfig wlan0 down...

Attachments (0)

Change History (3)

comment:1 Changed 9 years ago by florian

  • Resolution set to invalid
  • Status changed from new to closed

You are supposed to put mac80211 interfaces down the interface configure it and put it up again. This is not a bug.

comment:2 Changed 9 years ago by andrew@…

In which case the init job is busted, since the device has the wrong mode on system startup. I'm assuming because the wlan0 is up when it tries to change the mode to ad-hoc (I can't test this right now since I don't have a booting firmware on my WRT54GS).

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.