Modify

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#4937 closed defect (fixed)

xsupplicant doesn't compile due to missing iwlib.h

Reported by: maddes.b due to missing iwlib.h Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: xsupplicant iwlib.h Cc:

Description

Revision: r15213 /
Build Environment: Debian 5.0r0 /
Target: Marvel Orion, SquashFS image /
Call: make V=99

Error message:
checking for iwlib.h... no
configure: error: header file <iwlib.h> is required for Xsupplicant
make[3]: * /home/openwrt/kamikaze-trunk/build_dir/target-arm_uClibc-0.9.29/xsupplicant-1.2.8/.configured Error 1

Do I have to install another package?

Attachments (1)

002-iwlib_h_fix.patch (1.0 KB) - added by Maddes <maddes_trac@…> 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by maddes.b

Following packages are already installed:

root@debian5:~# dpkg -l | grep iw
ii  libiw-dev                         29-1.1                   Wireless tools - development files
ii  libiw29                           29-1.1                   Wireless tools - library

comment:2 Changed 9 years ago by ruff <rufferson@…>

That is caused by conflicting of linux/if.h included by test code and net/if.h included by iwlib.h.
I've handled it with such patch

ruff@merlin ~/openwrt/kamikadze $ cat package/wireless-tools/patches/002-iwlib_h_fix.patch
--- a/iwlib.h   2007-06-22 21:01:04.000000000 +0300
+++ b/iwlib.h   2009-04-24 17:30:40.000000000 +0300
@@ -53,9 +53,30 @@

 #include <linux/types.h>               /* for "caddr_t" et al          */

+#ifndef LINUX_VERSION_CODE
+#include <linux/version.h>
+#endif /* LINUX_VERSION_CODE */
+/* Check kernel version, new headers are supposed to be good! */
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
+#define _USE_LINUX_IF_H 1
+#endif /* >= */
+/* Check if net/if.h already been included */
+#ifdef _NET_IF_H
+#undef _USE_LINUX_IF_H
+#endif /* _NET_IF_H*/
+/* Check if linux/if.h already been included */
+#ifdef _LINUX_IF_H
+#define _USE_LINUX_IF_H 1
+#endif /* _LINUX_IF_H */
+
+#ifdef _USE_LINUX_IF_H
+#include <linux/socket.h>              /* for "struct sockaddr" et al  */
+#include <linux/if.h>                  /* for IFNAMSIZ and co... */
+#else
 /* Glibc systems headers are supposedly less problematic than kernel ones */
 #include <sys/socket.h>                        /* for "struct sockaddr" et al  */
 #include <net/if.h>                    /* for IFNAMSIZ and co... */
+#endif /* _USE_LINUX_IF_H */

 /* Private copy of Wireless extensions (in this directoty) */
 #include "wireless.h"

pay attantion to tabs, comments are alligned with tabs

Changed 9 years ago by Maddes <maddes_trac@…>

comment:3 Changed 9 years ago by Maddes <maddes_trac@…>

The above mentioned patch worked fine for me in r15557.
Please review it and add it to the repository.

I added the patch as an attachment for easier handling.
Just place it in package/wireless-tools/patches.

comment:4 Changed 9 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:5 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [15800], thanks!

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.