Modify

Opened 12 years ago

Closed 12 years ago

Last modified 4 years ago

#493 closed enhancement (fixed)

Kamikaze - JFFS2 - First Reboot - Aumatic Reboot

Reported by: consulting@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: jffs2 automatic reboot Cc:

Description

Using a Kamikaze JFFS2 image on a WGT634U requires a reboot after the mtd partition is restructured during the first boot after a flash cycle. Rather than just printing a message to the console, it would be nice if the device would just automatically reboot. The attached patch changes jffs2root and the script to add a new "--reboot" paramter to reboot the system using a system call as the init process is not yet run. The only risk I see in this method at the moment is if the mtd device possibly returns before the erase/write cycle is fully completed. For what its worth, I've been running this version of the patch for over a month now without any problems.

Attachments (1)

jffs2root-auto-reboot.patch (2.5 KB) - added by consulting@… 12 years ago.
Sample patch

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by consulting@…

Sample patch

comment:1 Changed 12 years ago by mbm

You're fixing the symptoms and not the cause.

The jffs2root utility changes the mtd partitions, and since the kernel currently lacks any way to recalculate the partition offsets, a reboot is used.

(Also, I could have sworn there was already another ticket open for this)

comment:2 Changed 12 years ago by consulting@…

Agreed, its definitely a bandaid for the root problem, but at the moment I'm not entirely sure what the correct solution would entail so I'm just making the current solution automated.

If there was already an open ticket for this issue, sorry, I didn't think I saw one but it may be describing the root problem and I just didn't connect the two - it appears I'm also having trouble with spelling today too...;)

comment:3 Changed 12 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

OpenWrt no longer requires a reboot for jffs2 images.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.